summaryrefslogtreecommitdiff
path: root/plugins/ffap
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ffap')
-rw-r--r--plugins/ffap/Makefile.am4
-rw-r--r--plugins/ffap/ffap.c4
2 files changed, 4 insertions, 4 deletions
diff --git a/plugins/ffap/Makefile.am b/plugins/ffap/Makefile.am
index 736392c3..4f6ce038 100644
--- a/plugins/ffap/Makefile.am
+++ b/plugins/ffap/Makefile.am
@@ -3,8 +3,8 @@ ffapdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = ffap.la
topsrcdir = @top_srcdir@
-EXTRA_PROGRAMS = foo
YASM=$(topsrcdir)/yasmwrapper.sh
+EXTRA_DIST = dsputil_yasm.asm x86inc.asm
SUFFIXES = .asm
if HAVE_YASM
@@ -19,7 +19,7 @@ if HAVE_YASM
$(LIBTOOL) --tag=CC --mode=compile $(YASM) $(YASM_FLAGS) -o $@ $<
endif
-ffap_la_LDFLAGS = -module
+ffap_la_LDFLAGS = -module -lm
AM_CFLAGS = $(CFLAGS) -fPIC -std=c99
endif
diff --git a/plugins/ffap/ffap.c b/plugins/ffap/ffap.c
index ccfa2b2d..c2ba7cbd 100644
--- a/plugins/ffap/ffap.c
+++ b/plugins/ffap/ffap.c
@@ -1,6 +1,6 @@
/*
DeaDBeeF - ultimate music player for GNU/Linux systems with X11
- Copyright (C) 2009-2011 Alexey Yakovenko <waker@users.sourceforge.net>
+ Copyright (C) 2009-2012 Alexey Yakovenko <waker@users.sourceforge.net>
based on apedec from FFMpeg Copyright (c) 2007 Benjamin Zores <ben@geexbox.org>
based upon libdemac from Dave Chapman.
@@ -1870,7 +1870,7 @@ static DB_decoder_t plugin = {
.plugin.name = "Monkey's Audio (APE) decoder",
.plugin.descr = "APE player based on code from libavc and rockbox",
.plugin.copyright =
- "Copyright (C) 2009-2011 Alexey Yakovenko <waker@users.sourceforge.net>\n"
+ "Copyright (C) 2009-2012 Alexey Yakovenko <waker@users.sourceforge.net>\n"
"\n"
"based on apedec from FFMpeg Copyright (c) 2007 Benjamin Zores <ben@geexbox.org>\n"
"based upon libdemac from Dave Chapman.\n"