summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eb34044b..ff4ad333 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,7 @@ PKG_CHECK_MODULES(DEPS, samplerate)
PKG_CHECK_MODULES(GTKUI_DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0, HAVE_GTK=1, NO_GTK=1)
PKG_CHECK_MODULES(ALSA_DEPS, alsa, HAVE_ALSA=1, NO_ALSA=1)
PKG_CHECK_MODULES(FFMPEG_DEPS, libavcodec libavutil libavformat >= 52.0.0, HAVE_FFMPEG=1, NO_FFMPEG=1)
+PKG_CHECK_MODULES(NOTIFICATION_DEPS, libnotify, HAVE_LIBNOTIFY=1, NO_LIBNOTIFY=1)
AC_CHECK_LIB([pthread], [main])
AC_CHECK_LIB([dl], [main])
@@ -172,6 +173,14 @@ if test ${HAVE_FFMPEG}; then
AC_SUBST(FFMPEG_DIR)
fi
+AM_CONDITIONAL(HAVE_LIBNOTIFY, test $HAVE_LIBNOTIFY)
+if test ${HAVE_LIBNOTIFY}; then
+ NOTIFICATION_DIR="plugins/notification"
+ AC_SUBST(NOTIFICATION_DEPS_CFLAGS)
+ AC_SUBST(NOTIFICATION_DEPS_LIBS)
+ AC_SUBST(NOTIFICATION_DIR)
+fi
+
dnl print summary
echo
echo "plugin summary:"
@@ -207,6 +216,7 @@ dnl PRINT_PLUGIN_INFO([faad2],[aac/mp4 player],[test $HAVE_FAAD && test $HAVE_MP
PRINT_PLUGIN_INFO([cdda],[cd audio player],[test $HAVE_CDIO && test $HAVE_CDDB])
PRINT_PLUGIN_INFO([gtkui],[GTK user interface],[test $HAVE_GTK])
PRINT_PLUGIN_INFO([ffmpeg],[ffmpeg codecs],[test $HAVE_FFMPEG])
+PRINT_PLUGIN_INFO([notification],[Current track notification],[true])
echo
AC_OUTPUT([
@@ -233,6 +243,7 @@ plugins/nullout/Makefile
plugins/vtx/Makefile
plugins/adplug/Makefile
plugins/ffmpeg/Makefile
+plugins/notification/Makefile
deadbeef.desktop
])