summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--plugins/adplug/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/adplug/Makefile.am b/plugins/adplug/Makefile.am
index 393f2d59..c125a056 100644
--- a/plugins/adplug/Makefile.am
+++ b/plugins/adplug/Makefile.am
@@ -4,10 +4,10 @@ adplugpath=@top_srcdir@/plugins/adplug
adlibdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = adplug.la
-AM_CFLAGS = $(CFLAGS) -std=c99 -I$(adplugpath)/adplug -I$(adplugpath)/libbinio
+AM_CFLAGS = $(CFLAGS) -std=c99 -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fPIC
adplug_la_LDFLAGS = -module -nostdlib -lsupc++
-AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables
+AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables -fPIC
adplug_la_SOURCES = plugin.c\
adplug-db.cpp\