summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am23
-rw-r--r--configure.ac1
2 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f8e7c511..0bf99b0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ SUBDIRS = gme/Game_Music_Emu-0.5.2\
gme/Game_Music_Emu-0.5.2/gme\
sid/sidplay-libs-2.1.0\
dumb\
+ pixmaps\
icons\
plugins/hotkeys\
plugins/ffap\
@@ -62,3 +63,25 @@ desktopdir = $(datadir)/applications
desktop_DATA = deadbeef.desktop
EXTRA_DIST = $(docs_DATA) $(desktop_DATA)
+
+#install-data-local:
+# @$(NORMAL_INSTALL)
+# if test -d $(srcdir)/pixmaps; then \
+# $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
+# for pixmap in $(srcdir)/pixmaps/*; do \
+# if test -f $$pixmap; then \
+# $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
+# fi \
+# done \
+# fi
+#
+#dist-hook:
+# if test -d pixmaps; then \
+# mkdir $(distdir)/pixmaps; \
+# for pixmap in pixmaps/*; do \
+# if test -f $$pixmap; then \
+# cp -p $$pixmap $(distdir)/pixmaps; \
+# fi \
+# done \
+# fi
+#
diff --git a/configure.ac b/configure.ac
index 0ff6ba96..327ebcf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,6 +176,7 @@ echo
AC_OUTPUT([
Makefile
+pixmaps/Makefile
icons/Makefile
gme/Game_Music_Emu-0.5.2/Makefile
gme/Game_Music_Emu-0.5.2/gme/Makefile