summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-05-10 22:57:03 +0200
committerGravatar waker <wakeroid@gmail.com>2011-05-10 23:09:48 +0200
commitace1e33f4808c55e57c2d8219c59bebde7cc852b (patch)
tree69a0e59e00cc16be60530ec6401a0d34c624c39e /plugins
parent32a2a4cea0d9397d7cd618c8ce835aac980fe359 (diff)
0.5.0-rc1 final fixups
Diffstat (limited to 'plugins')
-rw-r--r--plugins/converter/converter.h2
-rw-r--r--plugins/dsp_libsrc/src.c4
-rw-r--r--plugins/gme/cgme.c4
-rw-r--r--plugins/gtkui/Makefile.am3
-rw-r--r--plugins/gtkui/dspconfig.c2
-rw-r--r--plugins/sid/plugin.c3
-rw-r--r--plugins/supereq/Makefile.am2
-rw-r--r--plugins/vtx/vtx.c2
8 files changed, 11 insertions, 11 deletions
diff --git a/plugins/converter/converter.h b/plugins/converter/converter.h
index 173d35b4..36daa023 100644
--- a/plugins/converter/converter.h
+++ b/plugins/converter/converter.h
@@ -20,7 +20,7 @@
#define __CONVERTER_H
#include <stdint.h>
-#include <deadbeef.h>
+#include "../../deadbeef.h"
enum {
DDB_ENCODER_METHOD_PIPE = 0,
diff --git a/plugins/dsp_libsrc/src.c b/plugins/dsp_libsrc/src.c
index be9c350e..2c909e3d 100644
--- a/plugins/dsp_libsrc/src.c
+++ b/plugins/dsp_libsrc/src.c
@@ -20,9 +20,7 @@
#include <stdlib.h>
#include <string.h>
#include <assert.h>
-#include "conf.h"
-#include "threading.h"
-#include "deadbeef.h"
+#include "../../deadbeef.h"
#include "src.h"
//#define trace(...) { fprintf(stderr, __VA_ARGS__); }
diff --git a/plugins/gme/cgme.c b/plugins/gme/cgme.c
index 57788851..01f81e10 100644
--- a/plugins/gme/cgme.c
+++ b/plugins/gme/cgme.c
@@ -413,8 +413,8 @@ static DB_decoder_t plugin = {
.plugin.version_minor = 0,
.plugin.type = DB_PLUGIN_DECODER,
.plugin.id = "stdgme",
- .plugin.name = "Game_Music_Emu decoder",
- .plugin.descr = "chiptune music player based on GME",
+ .plugin.name = "Game-Music-Emu player",
+ .plugin.descr = "chiptune/game music player based on GME library",
.plugin.copyright =
"Copyright (C) 2009-2011 Alexey Yakovenko <waker@users.sourceforge.net>\n"
"\n"
diff --git a/plugins/gtkui/Makefile.am b/plugins/gtkui/Makefile.am
index 3cfc1cce..d89f0f6c 100644
--- a/plugins/gtkui/Makefile.am
+++ b/plugins/gtkui/Makefile.am
@@ -35,7 +35,8 @@ GTKUI_SOURCES = gtkui.c gtkui.h\
actions.c actions.h\
dspconfig.c dspconfig.h\
tagwritersettings.c tagwritersettings.h\
- wingeom.c wingeom.h
+ wingeom.c wingeom.h\
+ pluginconf.h
sdkdir = $(pkgincludedir)
sdk_HEADERS = gtkui_api.h
diff --git a/plugins/gtkui/dspconfig.c b/plugins/gtkui/dspconfig.c
index 38ec5b9a..8975c7ec 100644
--- a/plugins/gtkui/dspconfig.c
+++ b/plugins/gtkui/dspconfig.c
@@ -31,7 +31,7 @@
#include "callbacks.h"
#include "interface.h"
#include "support.h"
-#include "deadbeef.h"
+#include "../../deadbeef.h"
#include "gtkui.h"
#include "pluginconf.h"
diff --git a/plugins/sid/plugin.c b/plugins/sid/plugin.c
index 6c4705b5..1892d598 100644
--- a/plugins/sid/plugin.c
+++ b/plugins/sid/plugin.c
@@ -33,7 +33,8 @@ DB_decoder_t sid_plugin = {
.plugin.type = DB_PLUGIN_DECODER,
.plugin.version_major = 1,
.plugin.version_minor = 0,
- .plugin.name = "SID decoder",
+ .plugin.name = "SID player",
+ .plugin.id = "sidplay2",
.plugin.descr = "SID player based on libsidplay2",
.plugin.copyright =
"Copyright (C) 2009-2011 Alexey Yakovenko <waker@users.sourceforge.net>\n"
diff --git a/plugins/supereq/Makefile.am b/plugins/supereq/Makefile.am
index 45010ec8..4ce19ee5 100644
--- a/plugins/supereq/Makefile.am
+++ b/plugins/supereq/Makefile.am
@@ -1,7 +1,7 @@
if HAVE_SUPEREQ
supereqdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = supereq.la
-supereq_la_SOURCES = supereq.c supereq.h Equ.cpp Fftsg_fl.cpp paramlist.hpp
+supereq_la_SOURCES = supereq.c Equ.cpp Equ.h Fftsg_fl.cpp paramlist.hpp
#nsfft-1.00/simd/SIMDBaseUndiff.c\
#nsfft-1.00/simd/SIMDBase.c\
diff --git a/plugins/vtx/vtx.c b/plugins/vtx/vtx.c
index ffb14c7e..c42715db 100644
--- a/plugins/vtx/vtx.c
+++ b/plugins/vtx/vtx.c
@@ -303,7 +303,7 @@ static DB_decoder_t plugin = {
.plugin.version_minor = 0,
.plugin.type = DB_PLUGIN_DECODER,
.plugin.id = "vtx",
- .plugin.name = "VTX decoder",
+ .plugin.name = "VTX player",
.plugin.descr = "AY8910/12 chip emulator and vtx file player",
.plugin.copyright =
"Copyright (C) 2009-2011 Alexey Yakovenko <waker@users.sourceforge.net>\n"