summaryrefslogtreecommitdiff
path: root/plugins/supereq
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-04-12 20:22:53 +0200
committerGravatar waker <wakeroid@gmail.com>2012-04-12 20:22:53 +0200
commit1d06cdb31bc39106ab50999a2b4f0b9acf8ffc19 (patch)
tree3e102ec245afb3ee77d4d0e0450dc3ca5e27adf7 /plugins/supereq
parent7420ed88b753badcdf51e9c9b731765658bde2c4 (diff)
vis buffer is now always float/mono
Diffstat (limited to 'plugins/supereq')
-rw-r--r--plugins/supereq/Fftsg_fl.c (renamed from plugins/supereq/Fftsg_fl.cpp)3
-rw-r--r--plugins/supereq/Makefile.am43
2 files changed, 1 insertions, 45 deletions
diff --git a/plugins/supereq/Fftsg_fl.cpp b/plugins/supereq/Fftsg_fl.c
index 636f8b8a..d66ae896 100644
--- a/plugins/supereq/Fftsg_fl.cpp
+++ b/plugins/supereq/Fftsg_fl.c
@@ -285,8 +285,6 @@ Appendix :
w[] and ip[] are compatible with all routines.
*/
-extern "C" {
-
void cdft(int n, int isgn, REAL *a, int *ip, REAL *w)
{
void makewt(int nw, int *ip, REAL *w);
@@ -2650,4 +2648,3 @@ void dstsub(int n, REAL *a, int nc, REAL *c)
}
a[m] *= c[0];
}
-}
diff --git a/plugins/supereq/Makefile.am b/plugins/supereq/Makefile.am
index 4ce19ee5..0096e4ab 100644
--- a/plugins/supereq/Makefile.am
+++ b/plugins/supereq/Makefile.am
@@ -1,48 +1,7 @@
if HAVE_SUPEREQ
supereqdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = supereq.la
-supereq_la_SOURCES = supereq.c Equ.cpp Equ.h Fftsg_fl.cpp paramlist.hpp
-
-#nsfft-1.00/simd/SIMDBaseUndiff.c\
-#nsfft-1.00/simd/SIMDBase.c\
-#nsfft-1.00/dft/DFT.c\
-#nsfft-1.00/dft/DFTUndiff.c\
-#nsfft-1.00/simd/SIMDBase.h\
-#nsfft-1.00/simd/SIMDBaseUndiff.h\
-#nsfft-1.00/dft/DFTUndiff.h\
-#nsfft-1.00/dft/DFT.h\
-#shibatch_rdft.c
-
-#ffmpeg_fft/libavutil/mem.c\
-#ffmpeg_fft/libavutil/mathematics.c\
-#ffmpeg_fft/libavutil/rational.c\
-#ffmpeg_fft/libavutil/intfloat_readwrite.c\
-#ffmpeg_fft/libavcodec/dct.c\
-#ffmpeg_fft/libavcodec/avfft.c\
-#ffmpeg_fft/libavcodec/fft.c\
-#ffmpeg_fft/libavcodec/dct32.c\
-#ffmpeg_fft/libavcodec/rdft.c\
-#ffmpeg_fft/libavutil/intfloat_readwrite.h\
-#ffmpeg_fft/libavutil/avutil.h\
-#ffmpeg_fft/libavutil/common.h\
-#ffmpeg_fft/libavutil/attributes.h\
-#ffmpeg_fft/libavutil/mem.h\
-#ffmpeg_fft/libavutil/avconfig.h\
-#ffmpeg_fft/libavutil/mathematics.h\
-#ffmpeg_fft/libavutil/rational.h\
-#ffmpeg_fft/publik.h\
-#ffmpeg_fft/ffmpeg_fft.h\
-#ffmpeg_fft/libavcodec/dct32.h\
-#ffmpeg_fft/libavcodec/fft.h\
-#ffmpeg_fft/libavcodec/avfft.h\
-#ffmpeg_fft/config.h\
-#ff_rdft.c
-
-#AM_CFLAGS = $(CFLAGS) -I ffmpeg_fft -I ffmpeg_fft/libavcodec -I ffmpeg_fft/libavutil -std=c99
-#AM_CPPFLAGS = $(CXXFLAGS) -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables -I ffmpeg_fft -I ffmpeg_fft/libavcodec -I ffmpeg_fft/libavutil
-
-#AM_CFLAGS = $(CFLAGS) -I nsfft-1.00/dft -I nsfft-1.00/simd -std=c99 -msse -DENABLE_SSE_FLOAT -DUSE_SHIBATCH
-#AM_CPPFLAGS = $(CXXFLAGS) -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables -I nsfft-1.00/dft -I nsfft-1.00/simd -msse -DENABLE_SSE_FLOAT -DUSE_SHIBATCH
+supereq_la_SOURCES = supereq.c Equ.cpp Equ.h Fftsg_fl.c paramlist.hpp
AM_CFLAGS = $(CFLAGS) -std=c99 -DUSE_OOURA
AM_CPPFLAGS = $(CXXFLAGS) -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables -DUSE_OOURA