summaryrefslogtreecommitdiff
path: root/plugins/shn
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-02-24 20:33:06 +0100
committerGravatar waker <wakeroid@gmail.com>2011-02-24 20:33:06 +0100
commitc05c4393fc9bc38f73961afe67b0b950ccec328e (patch)
treef5e20e256ea8e851272d73258d9ac12cf0079afb /plugins/shn
parenta9d8c7570725c5c8c6896289520d145deaeeb3e4 (diff)
fixed dumb and shn -fPIC makefile bug
Diffstat (limited to 'plugins/shn')
-rw-r--r--plugins/shn/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
index f60ea3bd..7ce0e430 100644
--- a/plugins/shn/Makefile
+++ b/plugins/shn/Makefile
@@ -2,9 +2,9 @@ OUT=shn.so
CC=gcc
-CFLAGS+=-Wall -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
+CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I. -I../..
-LDFLAGS+=-module -shared -fPIC -lm
+LDFLAGS+=-module -shared -lm
SOURCES=array.c convert.c misc.c output.c seek.c shn.c shorten.c sulawalaw.c vario.c wave.c