summaryrefslogtreecommitdiff
path: root/plugins/shellexec/Makefile.am
diff options
context:
space:
mode:
authorGravatar Viktor Semykin <thesame.ml@gmail.com>2010-05-25 03:37:44 +0300
committerGravatar Viktor Semykin <thesame.ml@gmail.com>2010-05-25 03:37:44 +0300
commit8c012917f5530d947c1a31adfc6aba4b0cf3853c (patch)
treef9183ee845fd497006dde0c5f80049714a15d9a4 /plugins/shellexec/Makefile.am
parentbe0f4b1926f7e77c7e03eae7b70ec12f1b905025 (diff)
Misc plugin actions
Diffstat (limited to 'plugins/shellexec/Makefile.am')
-rw-r--r--plugins/shellexec/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/shellexec/Makefile.am b/plugins/shellexec/Makefile.am
new file mode 100644
index 00000000..65d6a5b8
--- /dev/null
+++ b/plugins/shellexec/Makefile.am
@@ -0,0 +1,9 @@
+if HAVE_SHELLEXEC
+shxdir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = shellexec.la
+shellexec_la_SOURCES = shellexec.c
+shellexec_la_LDFLAGS = -module
+
+shellexec_la_LIBADD = $(LDADD) $(HOTKEYS_LIBS)
+AM_CFLAGS = $(CFLAGS) -std=c99
+endif