summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-11-22 23:06:02 +0100
committerGravatar waker <wakeroid@gmail.com>2010-11-23 19:50:28 +0100
commitcb4a7640cc1cba197a37bd8c3215096ba7d10102 (patch)
tree9b9831f58309aab6061ed04bfd8dbfa5594bb88e /configure.ac
parent61475f37b4c51578bd13c6c3aa49cb2bb7321864 (diff)
ported gme plugin to new API; added VGZ format support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3102fef1..0974b2e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,15 @@ test "x$prefix" = xNONE && prefix=$ac_default_prefix
PKG_CHECK_MODULES(DEPS, samplerate)
+if test "x$enable_staticlink" != "xno" ; then
+ HAVE_ZLIB=yes
+ ZLIB_LIBS="../../$LIB/libz.a"
+else
+ AC_CHECK_LIB([z], [main], [HAVE_ZLIB=yes])
+ ZLIB_LIBS="-lz"
+fi
+AC_SUBST(ZLIB_LIBS)
+
dnl INSANE_CFLAGS="-Wformat -Wdisabled-optimization -Wcomment -Wchar-subscripts -Wunused-function -Wunused-value -Wuninitialized -Wtype-limits -Wbad-function-cast"
dnl INSANE_CXXFLAGS="-Wcomment -Wchar-subscripts -Wunused-function -Wunused-value -Wuninitialized -Wtype-limits"
@@ -485,15 +494,7 @@ if test "x$enable_shn" != "xno" ; then
fi
if test "x$enable_ao" != "xno" ; then
-if test "x$enable_staticlink" != "xno" ; then
- HAVE_ZLIB=yes
- ZLIB_LIBS="../../$LIB/libz.a"
-else
- AC_CHECK_LIB([z], [main], [HAVE_ZLIB=yes])
- ZLIB_LIBS="-lz"
-fi
if test "x$HAVE_ZLIB" = "xyes"; then
- AC_SUBST(ZLIB_LIBS)
HAVE_AO=yes
fi
fi