diff options
author | Alexey Yakovenko <waker@users.sourceforge.net> | 2014-02-09 20:53:09 +0100 |
---|---|---|
committer | Alexey Yakovenko <waker@users.sourceforge.net> | 2014-02-09 20:53:09 +0100 |
commit | 05b1a9c505cf217cd54ab3724e80f7b7841cfcf7 (patch) | |
tree | 898ff4e39d8fc663fd96f7d548fe0e54465d03e8 | |
parent | 60b4548980c6f8d3b51d72a986e37cabf4faa7ba (diff) |
fixed flac and alsa static build issues, added gittip badge to the README.md
-rw-r--r-- | README.md | 2 | ||||
-rw-r--r-- | configure.ac | 11 | ||||
-rw-r--r-- | plugins/artwork/Makefile.am | 4 |
3 files changed, 14 insertions, 3 deletions
@@ -4,6 +4,8 @@ DeaDBeeF is a music player for \*nix-like systems. More info is [here](http://deadbeef.sf.net). +[![Support via Gittip](https://rawgithub.com/twolfson/gittip-badge/0.1.0/dist/gittip.png)](https://www.gittip.com/Alexey-Yakovenko/) + ## Build Status on drone.io [![Build Status](https://drone.io/github.com/Alexey-Yakovenko/deadbeef/status.png)](https://drone.io/github.com/Alexey-Yakovenko/deadbeef/latest) diff --git a/configure.ac b/configure.ac index 3832c70d..36fafcaf 100644 --- a/configure.ac +++ b/configure.ac @@ -235,7 +235,16 @@ dnl AC_CHECK_LIB([ICE], [main], [HAVE_ICE=yes;ICE_LIBS="-lICE";AC_SUBST(ICE_L ]) AS_IF([test "${enable_alsa}" != "no"], [ - PKG_CHECK_MODULES(ALSA_DEPS, alsa, HAVE_ALSA=yes, HAVE_ALSA=no) + AS_IF([test "${enable_staticlink}" != "no"], [ + HAVE_ALSA=yes + ALSA_DEPS_CFLAGS="-I../../$LIB/include/alsa" + ALSA_DEPS_LIBS="-lasound" + AC_SUBST(ALSA_DEPS_CFLAGS) + AC_SUBST(ALSA_DEPS_LIBS) + ], + [ + PKG_CHECK_MODULES(ALSA_DEPS, alsa, HAVE_ALSA=yes, HAVE_ALSA=no) + ]) ]) AC_CHECK_HEADER([CoreAudio/AudioHardware.h], [found_coreaudio_h=yes], [found_coreaudio_h=no]) diff --git a/plugins/artwork/Makefile.am b/plugins/artwork/Makefile.am index 5948af9b..d0f54a57 100644 --- a/plugins/artwork/Makefile.am +++ b/plugins/artwork/Makefile.am @@ -15,9 +15,9 @@ endif if HAVE_FLAC FLAC_DEPS=$(FLAC_LIBS) -FLAC_CFLAGS=-DUSE_METAFLAC +flac_clags=-DUSE_METAFLAC $(FLAC_CFLAGS) endif -AM_CFLAGS = $(CFLAGS) $(ARTWORK_CFLAGS) $(FLAC_CFLAGS) -std=c99 +AM_CFLAGS = $(CFLAGS) $(ARTWORK_CFLAGS) $(flac_cflags) -std=c99 artwork_la_LIBADD = $(LDADD) $(ARTWORK_DEPS) $(FLAC_DEPS) endif |