summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-02-26 20:14:00 +0100
committerGravatar waker <wakeroid@gmail.com>2011-02-26 20:14:00 +0100
commitf5d99624cccecf90f26eb12c64406feccbcc1050 (patch)
tree124d5dd2725a48c4018e12d3972dff7c51a202ee
parent8a723b58c7776a6606e977bbeacdc4fd89d0f830 (diff)
proper imlib2 checking for artwork plugin
-rw-r--r--configure.ac3
-rw-r--r--plugins/artwork/Makefile.am4
2 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 12bd7201..34cc83a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -405,7 +405,8 @@ if test "x$enable_shellexec" != "xno" ; then
fi
if test "x$enable_artwork" != "xno" ; then
- if test "x$HAVE_CURL" = "xyes" && test "x$HAVE_VFS_CURL" = "xyes" ; then
+ PKG_CHECK_MODULES(IMLIB2_DEPS, imlib2, HAVE_IMLIB2=yes, HAVE_IMLIB2=no)
+ if test "x$HAVE_CURL" = "xyes" && test "x$HAVE_VFS_CURL" = "xyes" && test "x$HAVE_IMLIB2" == "xyes" ; then
HAVE_ARTWORK=yes
fi
fi
diff --git a/plugins/artwork/Makefile.am b/plugins/artwork/Makefile.am
index 4ca2ed19..8f9ea166 100644
--- a/plugins/artwork/Makefile.am
+++ b/plugins/artwork/Makefile.am
@@ -5,6 +5,6 @@ artwork_la_SOURCES = artwork.c artwork.h albumartorg.c albumartorg.h lastfm.c la
artwork_la_LDFLAGS = -module
-artwork_la_LIBADD = $(LDADD) $(ARTWORK_DEPS_LIBS) -lImlib2
-AM_CFLAGS = -std=c99 $(ARTWORK_DEPS_CFLAGS)
+artwork_la_LIBADD = $(LDADD) $(ARTWORK_DEPS_LIBS) $(IMLIB2_DEPS_LIBS)
+AM_CFLAGS = -std=c99 $(ARTWORK_DEPS_CFLAGS) $(IMLIB2_DEPS_CFLAGS)
endif