summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
3 files changed, 10 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7d341668..99b6e54b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+coq (8.1.pl1+dfsg-3) UNRELEASED; urgency=low
+
+ * Depend on ocaml-base-nox since coq_makefile needs ocamlrun.
+
+ -- Samuel Mimram <smimram@debian.org> Mon, 27 Aug 2007 09:28:38 +0200
+
coq (8.1.pl1+dfsg-2) experimental; urgency=low
* Updated for OCaml 3.10.
diff --git a/debian/control b/debian/control
index 7c473bf4..3824703e 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ XS-Vcs-Browser: http://svn.debian.org/wsvn/pkg-ocaml-maint/trunk/packages/coq/tr
Package: coq
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, coq-libs (= ${source:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends}, ocaml-base-nox-${F:OCamlABI}, coq-libs (= ${source:Version})
Recommends: coqide | proofgeneral-coq
Suggests: ocaml-nox (>= 3.08), proofgeneral-coq, ledit, cle, coq-doc
Description: proof assistant for higher-order logic (toplevel and compiler)
diff --git a/debian/rules b/debian/rules
index d897124b..22cd9dc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,6 +13,8 @@ include /usr/share/dpatch/dpatch.make
COQPREF := $(CURDIR)/debian/tmp
ADDPREF := COQINSTALLPREFIX=$(COQPREF)
+OCAMLABI := $(shell ocamlc -version)
+
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man --emacslib /usr/share/emacs/site-lisp/coq --reals all --fsets all
configure: configure-stamp
@@ -128,7 +130,7 @@ binary-common:
dh_fixperms
dh_installdeb
dh_shlibdeps
- dh_gencontrol
+ dh_gencontrol -- -VF:OCamlABI="$(OCAMLABI)"
dh_md5sums
dh_builddeb