summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/00list2
-rwxr-xr-xdebian/patches/assert.dpatch19
-rwxr-xr-xdebian/patches/system.dpatch19
3 files changed, 20 insertions, 20 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index 826a242c..5e873f10 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,4 +1,4 @@
coqdoc_stdlib
browser
makefile
-assert
+system
diff --git a/debian/patches/assert.dpatch b/debian/patches/assert.dpatch
deleted file mode 100755
index 16a62f5f..00000000
--- a/debian/patches/assert.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## assert.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Check assertions in native mode too.
-
-@DPATCH@
-diff -urNad coq-8.0pl3+8.1beta.2~/Makefile coq-8.0pl3+8.1beta.2/Makefile
---- coq-8.0pl3+8.1beta.2~/Makefile 2006-06-25 22:17:49.000000000 +0000
-+++ coq-8.0pl3+8.1beta.2/Makefile 2006-07-13 16:27:10.000000000 +0000
-@@ -74,7 +74,7 @@
- MLINCLUDES=$(LOCALINCLUDES) -I $(MYCAMLP4LIB)
-
- BYTEFLAGS=$(MLINCLUDES) $(CAMLDEBUG) $(USERFLAGS)
--OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS) -noassert
-+OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS)
- OCAMLDEP=ocamldep
- DEPFLAGS=$(LOCALINCLUDES)
-
diff --git a/debian/patches/system.dpatch b/debian/patches/system.dpatch
new file mode 100755
index 00000000..ab8bded8
--- /dev/null
+++ b/debian/patches/system.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## system.dpatch by Hugo Herbelin <hugo.herbelin@inria.fr>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix interpretation of ~.
+
+@DPATCH@
+diff -urNad coq-8.1~gamma~/lib/system.ml coq-8.1~gamma/lib/system.ml
+--- coq-8.1~gamma~/lib/system.ml 2006-05-30 16:37:04.000000000 +0000
++++ coq-8.1~gamma/lib/system.ml 2006-11-21 21:12:08.000000000 +0000
+@@ -43,7 +43,7 @@
+ let v = safe_getenv (String.sub s (i+1) (n-i-1)) in
+ let s = (String.sub s 0 i)^v^(String.sub s n (l-n)) in
+ expand_macros s (i + String.length v)
+- | '~' ->
++ | '~' when i = 0 ->
+ let n = expand_atom s (i+1) in
+ let v =
+ if n=i+1 then home