summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/00list2
-rwxr-xr-xdebian/patches/ocaml309.dpatch24
-rwxr-xr-xdebian/patches/text_view_typing_error.dpatch31
3 files changed, 0 insertions, 57 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index ff826cb0..e69de29b 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,2 +0,0 @@
-ocaml309
-text_view_typing_error
diff --git a/debian/patches/ocaml309.dpatch b/debian/patches/ocaml309.dpatch
deleted file mode 100755
index e116bf0e..00000000
--- a/debian/patches/ocaml309.dpatch
+++ /dev/null
@@ -1,24 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## ocaml309.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Correct a compilation issue with OCaml 3.09.
-
-@DPATCH@
-diff -urNad coq-8.0pl2~/Makefile coq-8.0pl2/Makefile
---- coq-8.0pl2~/Makefile 2005-01-21 18:15:12.000000000 +0100
-+++ coq-8.0pl2/Makefile 2005-11-21 19:51:38.000000000 +0100
-@@ -1453,11 +1453,11 @@
-
- .ml4.cmx:
- $(SHOW)'OCAMLOPT4 $<'
-- $(HIDE)$(OCAMLOPT) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) `$(CAMLP4DEPS) $<` -impl" -c -impl $<
-+ $(HIDE)$(OCAMLOPT) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) `$(CAMLP4DEPS) $<` -loc loc -impl" -c -impl $<
-
- .ml4.cmo:
- $(SHOW)'OCAMLC4 $<'
-- $(HIDE)$(OCAMLC) $(BYTEFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) `$(CAMLP4DEPS) $<` -impl" -c -impl $<
-+ $(HIDE)$(OCAMLC) $(BYTEFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) `$(CAMLP4DEPS) $<` -loc loc -impl" -c -impl $<
-
- #.v.vo:
- # $(BOOTCOQTOP) -compile $*
diff --git a/debian/patches/text_view_typing_error.dpatch b/debian/patches/text_view_typing_error.dpatch
deleted file mode 100755
index cc37d08a..00000000
--- a/debian/patches/text_view_typing_error.dpatch
+++ /dev/null
@@ -1,31 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## text_view_typing_error.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Avoid a typing error with recent versions of lablgtk2.
-
-@DPATCH@
-diff -urNad --exclude=CVS --exclude=.svn ./ide/undo.ml /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.ml
---- ./ide/undo.ml 2004-07-16 21:30:21.000000000 +0200
-+++ /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.ml 2005-09-07 21:19:54.000000000 +0200
-@@ -18,7 +18,7 @@
- | Insert (s,i,l) -> Delete (s,i,l)
- | Delete (s,i,l) -> Insert (s,i,l)
-
--class undoable_view (tv:Gtk.text_view Gtk.obj) =
-+class undoable_view (tv:[> Gtk.text_view ] Gtk.obj) =
- let undo_lock = ref true in
- object(self)
- inherit GText.view tv as super
-diff -urNad --exclude=CVS --exclude=.svn ./ide/undo.mli /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.mli
---- ./ide/undo.mli 2005-01-21 18:21:33.000000000 +0100
-+++ /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.mli 2005-09-07 21:20:07.000000000 +0200
-@@ -10,7 +10,7 @@
-
- (* An undoable view class *)
-
--class undoable_view : Gtk.text_view Gtk.obj ->
-+class undoable_view : [> Gtk.text_view ] Gtk.obj ->
- object
- inherit GText.view
- method undo : bool