summaryrefslogtreecommitdiff
path: root/debian/coqvars.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/coqvars.mk')
-rw-r--r--debian/coqvars.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/coqvars.mk b/debian/coqvars.mk
new file mode 100644
index 00000000..3cf8fe08
--- /dev/null
+++ b/debian/coqvars.mk
@@ -0,0 +1,12 @@
+# Current coq version
+COQ_VERSION ?= $(shell /usr/bin/coqc --version | grep version | sed 's/^.*version \(.*\) ([^)]*)$/\1/')
+
+# Current coq ABI
+COQ_ABI ?= $(shell cat /usr/lib/coq/abi)
+
+# Standard library path
+COQ_STDLIB_DIR ?= $(shell /usr/bin/coqc -where)
+
+# Directory for contributions
+# External libraries should go there
+COQ_USERCONTRIB_DIR ?= $(COQ_STDLIB_DIR)/user-contrib