summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template3
-rw-r--r--config/coq_config.mli9
2 files changed, 10 insertions, 2 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index e5061ebe..fc8af173 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -141,6 +141,9 @@ DOT=dot
DOTOPTS=-Tps
ODOCDOTOPTS=-dot -dot-reduce
+# Option to control compilation and installation of the documentation
+WITHDOC=WITHDOCOPT
+
# make or sed are bogus and believe lines not terminating by a return
# are inexistent
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 23d3efbd..3898a0f3 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 10122 2007-09-15 10:35:59Z letouzey $ i*)
+(*i $Id: coq_config.mli 11313 2008-08-07 11:15:03Z barras $ i*)
val local : bool (* local use (no installation) *)
@@ -28,12 +28,17 @@ val osdeplibs : string (* OS dependant link options for ocamlc *)
(* val defined : string list (* options for lib/ocamlpp *) *)
val version : string (* version number of Coq *)
-val versionsi : string (* version number of Coq\_SearchIsos *)
val date : string (* release date *)
val compile_date : string (* compile date *)
+val vo_magic_number : int
+val state_magic_number : int
val theories_dirs : string list
val contrib_dirs : string list
val exec_extension : string (* "" under Unix, ".exe" under MS-windows *)
val with_geoproof : bool ref (* to (de)activate functions specific to Geoproof with Coqide *)
+
+val browser : string
+(** default web browser to use, may be overriden by environment
+ variable COQREMOTEBROWSER *)