summaryrefslogtreecommitdiff
path: root/config/Makefile.template
diff options
context:
space:
mode:
Diffstat (limited to 'config/Makefile.template')
-rw-r--r--config/Makefile.template14
1 files changed, 8 insertions, 6 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 3ea7c7c9..1e611356 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -31,7 +31,7 @@ EMACSLIB="EMACSLIBDIRECTORY"
EMACS=EMACSCOMMAND
# Path to Coq distribution
-COQTOP=COQTOPDIRECTORY
+COQSRC=COQSRCDIRECTORY
VERSION=COQVERSION
# Directory containing Camlp4 binaries. Can be empty if camlp4 is in the PATH
@@ -48,6 +48,9 @@ CAMLP4O=CAMLP4TOOL
CAMLP4COMPAT=CAMLP4COMPATFLAGS
MYCAMLP4LIB="CAMLP4LIBDIRECTORY"
+# LablGTK
+COQIDEINCLUDES=LABLGTKINCLUDES
+
# Objective-Caml compile command
OCAMLC="BYTECAMLC"
OCAMLOPT="NATIVECAMLC"
@@ -62,7 +65,7 @@ CAMLOPTLINK="NATIVECAMLC"
CAMLMKTOP="CAMLMKTOPEXEC"
# Caml flags
-CAMLFLAGS=CAMLANNOTATEFLAG
+CAMLFLAGS=-rectypes CAMLANNOTATEFLAG
# Compilation debug flag
CAMLDEBUG=COQDEBUGFLAG
@@ -73,16 +76,15 @@ INLINEFLAG=COQINLINEFLAG
# User compilation flag
USERFLAGS=
+# Flags for GCC
+CFLAGS=CCOMPILEFLAGS
+
# Compilation profile flag
CAMLTIMEPROF=COQPROFILEFLAG
# The best compiler: native (=opt) or bytecode (=byte) if no native compiler
BEST=BESTCOMPILER
-# For Camlp4 use
-P4=$(COQTOP)/bin/$(ARCH)/call_camlp4 -I $(COQTOP)/src/parsing
-P4DEP=$(COQTOP)/bin/$(ARCH)/camlp4dep
-
# Your architecture
# Can be obtain by UNIX command arch
ARCH=ARCHITECTURE