summaryrefslogtreecommitdiff
path: root/Makefile.dep
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.dep')
-rw-r--r--Makefile.dep15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.dep b/Makefile.dep
new file mode 100644
index 00000000..30690fac
--- /dev/null
+++ b/Makefile.dep
@@ -0,0 +1,15 @@
+#######################################################################
+# v # The Coq Proof Assistant / The Coq Development Team #
+# <O___,, # INRIA-Rocquencourt & LRI-CNRS-Orsay #
+# \VV/ #############################################################
+# // # This file is distributed under the terms of the #
+# # GNU Lesser General Public License Version 2.1 #
+#######################################################################
+
+# This Makefile is designed to make the .ml files corresponding to .ml4 files
+
+include Makefile
+include .depend.camlp4
+
+.ml4.ml:
+ $(CAMLP4O) $(CAMLP4EXTENDFLAGS) pr_o.cmo `$(CAMLP4DEPS) $<` -impl $< > $@ || rm -f $@