summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-18 23:53:48 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-18 23:53:48 +0000
commit19ee9e6a99e8f033805c45cb7b47d2b84e706c46 (patch)
tree936fb2ec3e883c97a350c7cba7278f0480796e43 /debian/rules
parent12ac9238f46cba4693724082849df258db73ee2e (diff)
Depend on ocaml-base-nox if coq is compiled in bytecode.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 20 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 8e927795..fa8d268d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,23 +24,25 @@ build-stamp:
touch test-suite/success/debian.v8
if grep -q BEST=opt config/Makefile; \
then \
- $(MAKE) check \
- || (echo WARNING: NATIVE CODE COMPILATION FAILED \
- && echo Trying to build coq in bytecode instead \
- && $(MAKE) archclean clean \
- && touch test-suite/success/debian.v8 \
- && $(MAKE) BEST=byte HASCOQIDE=byte check \
- && echo NATIVE CODE COMPILATION FAILED \
- && echo Coq was built in bytecode instead); \
+ $(MAKE) check \
+ || (echo WARNING: NATIVE CODE COMPILATION FAILED \
+ && echo Trying to build coq in bytecode instead \
+ && $(MAKE) archclean clean \
+ && touch test-suite/success/debian.v8 \
+ && $(MAKE) BEST=byte HASCOQIDE=byte check \
+ && touch byte-stamp \
+ && echo NATIVE CODE COMPILATION FAILED \
+ && echo Coq was built in bytecode instead); \
else \
- $(MAKE) check; \
+ $(MAKE) check; \
+ touch byte-stamp; \
fi
touch build-stamp
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp
+ rm -f build-stamp configure-stamp byte-stamp
-$(MAKE) clean
-$(MAKE) archclean
@@ -85,7 +87,14 @@ binary-arch: build install
dh_fixperms
dh_installdeb
dh_shlibdeps
- dh_gencontrol
+ if [ -e byte-stamp ]; then \
+ dh_gencontrol -pcoq -u-Vocaml:Runtime="ocaml-base-nox"; \
+ else \
+ dh_gencontrol -pcoq -u-Vocaml:Runtime=""; \
+ fi
+ dh_gencontrol -pcoqide
+ dh_gencontrol -pcoq-libs
+ dh_gencontrol -pcoq7-libs
dh_md5sums
dh_builddeb