summaryrefslogtreecommitdiff
path: root/Makefile.build
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-07-04 13:28:38 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2009-07-04 13:28:38 +0200
commit3a420f4ad929e8372d32c735fd0fd89dfc0346a1 (patch)
tree943a01d103c1296dc7c07cb188af994354c4d9a3 /Makefile.build
parent1769cbaddea77112dd6f336316d8eb9a0945a1e6 (diff)
parente4282ea99c664d8d58067bee199cbbcf881b60d5 (diff)
Merge commit 'upstream/8.2.pl1+dfsg'
Diffstat (limited to 'Makefile.build')
-rw-r--r--Makefile.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.build b/Makefile.build
index 19f13f15..703c5884 100644
--- a/Makefile.build
+++ b/Makefile.build
@@ -6,7 +6,7 @@
# # GNU Lesser General Public License Version 2.1 #
#######################################################################
-# $Id: Makefile.build 11935 2009-02-17 16:14:07Z notin $
+# $Id: Makefile.build 12169 2009-06-06 21:43:23Z herbelin $
# Makefile for Coq
@@ -717,7 +717,7 @@ ifeq ($(BEST),opt)
endif
# csdpcert is not meant to be directly called by the user; we install
# it with libraries
- -$(MKDIR) -p $(FULLCOQLIB)/contrib/micromega
+ -$(MKDIR) $(FULLCOQLIB)/contrib/micromega
$(INSTALLBIN) $(CSDPCERT) $(FULLCOQLIB)/contrib/micromega
-$(INSTALLLIB) revision $(FULLCOQLIB)
@@ -960,7 +960,7 @@ else
endif
%.ml4.d: $(D_DEPEND_BEFORE_SRC) %.ml4
$(SHOW)'CAMLP4DEPS $<'
- $(HIDE)( /bin/echo -n '$*.cmo $*.cmx $*.ml4.ml.d $*.ml4-preprocessed: $(SEP)' && $(CAMLP4DEPS) "$<" ) > "$@" \
+ $(HIDE)( printf "%s" '$*.cmo $*.cmx $*.ml4.ml.d $*.ml4-preprocessed: $(SEP)' && $(CAMLP4DEPS) "$<" ) > "$@" \
|| ( RV=$$?; rm -f "$@"; exit $${RV} )
%.ml4.ml.d: $(D_DEPEND_BEFORE_SRC) %.ml4 $(D_DEPEND_AFTER_SRC) $(GENFILES) $(ML4FILES:.ml4=.ml) %.ml4.d