summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2019-02-02 19:06:46 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2019-02-05 10:43:26 -0500
commit956960a408a4fe67c7508bf3101d469b6465686d (patch)
tree4d36cbcdd652c19dd123befd4577ea9ae798cfbc
parent8300ef2c07a17451f594bcbd6f0689cafb87c3fb (diff)
Update packaging for Emacs mode deletion
Proof General has been designated as the official interface to Coq, and Coq no longer ships a separate Emacs mode. Update packaging to purge references to the Emacs mode.
-rw-r--r--debian/changelog2
-rw-r--r--debian/control1
-rw-r--r--debian/coq.emacsen-install45
-rw-r--r--debian/coq.emacsen-remove15
-rw-r--r--debian/coq.emacsen-startup21
-rw-r--r--debian/coq.install.in1
-rwxr-xr-xdebian/rules1
7 files changed, 2 insertions, 84 deletions
diff --git a/debian/changelog b/debian/changelog
index 451e241d..b918317d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
coq (8.9.0-1) UNRELEASED; urgency=medium
* New upstream release
+ * Coq no longer ships an Emacs mode; users should migrate to Proof
+ General (Closes: #736761, #854147, #877938)
-- Benjamin Barenblat <bbaren@debian.org> Sat, 02 Feb 2019 19:00:47 -0500
diff --git a/debian/control b/debian/control
index 29f85268..1ab54783 100644
--- a/debian/control
+++ b/debian/control
@@ -32,7 +32,6 @@ Package: coq
Architecture: any
Depends:
coq-theories (= ${binary:Version}),
- emacsen-common,
${ocaml:Depends},
${python3:Depends},
${shlibs:Depends},
diff --git a/debian/coq.emacsen-install b/debian/coq.emacsen-install
deleted file mode 100644
index 1ed8fe43..00000000
--- a/debian/coq.emacsen-install
+++ /dev/null
@@ -1,45 +0,0 @@
-#! /bin/sh -e
-# /usr/lib/emacsen-common/packages/install/coq
-
-# Written by Jim Van Zandt <jrv@vanzandt.mv.com>, borrowing heavily
-# from the install scripts for gettext by Santiago Vila
-# <sanvila@ctv.es> and octave by Dirk Eddelbuettel <edd@debian.org>.
-
-FLAVOR=$1
-PACKAGE=coq
-
-if [ ${FLAVOR} = emacs ]; then exit 0; fi
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-#FLAVORTEST=`echo $FLAVOR | cut -c-6`
-#if [ ${FLAVORTEST} = xemacs ] ; then
-# SITEFLAG="-no-site-file"
-#else
-# SITEFLAG="--no-site-file"
-#fi
-FLAGS="${SITEFLAG} -q -batch -l path.el -f batch-byte-compile"
-
-ELDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-ELCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-
-# Install-info-altdir does not actually exist.
-# Maybe somebody will write it.
-if test -x /usr/sbin/install-info-altdir; then
- echo install/${PACKAGE}: install Info links for ${FLAVOR}
- install-info-altdir --quiet --section "" "" --dirname=${FLAVOR} /usr/info/${PACKAGE}.info.gz
-fi
-
-install -m 755 -d ${ELCDIR}
-cd ${ELDIR}
-FILES=`echo *.el`
-cp ${FILES} ${ELCDIR}
-cd ${ELCDIR}
-
-cat << EOF > path.el
-(setq load-path (cons "." load-path) byte-compile-warnings nil)
-EOF
-${FLAVOR} ${FLAGS} ${FILES}
-rm -f *.el path.el
-
-exit 0
diff --git a/debian/coq.emacsen-remove b/debian/coq.emacsen-remove
deleted file mode 100644
index 02b6392c..00000000
--- a/debian/coq.emacsen-remove
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/coq
-
-FLAVOR=$1
-PACKAGE=coq
-
-if [ ${FLAVOR} != emacs ]; then
- if test -x /usr/sbin/install-info-altdir; then
- echo remove/${PACKAGE}: removing Info links for ${FLAVOR}
- install-info-altdir --quiet --remove --dirname=${FLAVOR} /usr/info/coq.info.gz
- fi
-
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-fi
diff --git a/debian/coq.emacsen-startup b/debian/coq.emacsen-startup
deleted file mode 100644
index 2a554d36..00000000
--- a/debian/coq.emacsen-startup
+++ /dev/null
@@ -1,21 +0,0 @@
-;; -*-emacs-lisp-*-
-;;
-;; Emacs startup file for the Debian GNU/Linux coq package
-;;
-;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
-;; Modified by Dirk Eddelbuettel <edd@debian.org>
-;; Adapted for dh-make by Jim Van Zandt <jrv@vanzandt.mv.com>
-
-;; The coq package follows the Debian/GNU Linux 'emacsen' policy and
-;; byte-compiles its elisp files for each 'emacs flavor' (emacs19,
-;; xemacs19, emacs20, xemacs20...). The compiled code is then
-;; installed in a subdirectory of the respective site-lisp directory.
-;; We have to add this to the load-path:
-
-(setq load-path (cons (concat "/usr/share/"
- (symbol-name flavor)
- "/site-lisp/coq") load-path))
-
-(setq auto-mode-alist (cons '("\\.v\\'" . coq-mode) auto-mode-alist))
-(autoload 'coq-mode "coq" "Major mode for editing Coq vernacular." t)
-
diff --git a/debian/coq.install.in b/debian/coq.install.in
index f2f5339f..8bc58451 100644
--- a/debian/coq.install.in
+++ b/debian/coq.install.in
@@ -16,7 +16,6 @@ usr/lib/coq/tools/coqdoc/coqdoc.sty
usr/lib/coq/tools/make-both-single-timing-files.py => usr/lib/coq/tools/make-both-single-timing-files
usr/lib/coq/tools/make-both-time-files.py => usr/lib/coq/tools/make-both-time-files
usr/lib/coq/tools/make-one-time-file.py => usr/lib/coq/tools/make-one-time-file
-usr/share/emacs/site-lisp/coq/
usr/share/man/man1/coqc*
usr/share/man/man1/coqdep*
usr/share/man/man1/coqdoc*
diff --git a/debian/rules b/debian/rules
index 7f7b8051..5083fdf8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,7 +34,6 @@ endif
CONFIGUREOPTS := -arch Linux -prefix /usr -mandir /usr/share/man \
-configdir /etc/xdg/coq \
- -emacslib /usr/share/emacs/site-lisp/coq \
-browser "/usr/bin/x-www-browser %s &" \
-coqide no \
-with-doc no \