summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2019-01-17 20:42:25 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2019-01-17 20:42:25 -0500
commit4b8ec4bcaa087e35b5a82afc2c325fee2a67f7a4 (patch)
treea6b0f426a5cbc9798d6f3efee19211f44ea50f83
parent5d3dc22cc205021e517a81943952655c51777083 (diff)
Correct environment variable settings when running tests
$PWD doesn’t work in Makefiles – Make expands $P (to the empty string) and passes `WD` literally to the shell. Replace `$PWD` with `$(shell pwd)`.
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7c820e03..8ffcd917 100755
--- a/debian/rules
+++ b/debian/rules
@@ -83,7 +83,7 @@ endif
.PHONY: override_dh_auto_test
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- CAML_LD_LIBRARY_PATH=$PWD/kernel/byterun COQLIB=$PWD \
+ CAML_LD_LIBRARY_PATH=$(shell pwd)/kernel/byterun COQLIB=$(shell pwd) \
$(MAKE) test-suite COMPLEXITY=
endif