summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2008-08-15 12:26:18 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2008-08-15 13:54:43 +0200
commitc2b0b6213988a0592da8b773064949c637f8b64d (patch)
tree7ef61d8fc1e6177f8fdac50c81fe134b514411da
parent80430f1fcfaf77869f931a52a22b78364858a188 (diff)
Add non-native-archs.dpatch
Fix FTBFS on non-native architectures (Closes: #495165)
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/non-native-archs.dpatch32
2 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index 3e9df43f..fb3801fa 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,3 +1,4 @@
no-complexity-test
check
use-env-in-coq-config
+non-native-archs
diff --git a/debian/patches/non-native-archs.dpatch b/debian/patches/non-native-archs.dpatch
new file mode 100755
index 00000000..cbb9f832
--- /dev/null
+++ b/debian/patches/non-native-archs.dpatch
@@ -0,0 +1,32 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## non-native-archs.dpatch by Stephane Glondu <steph@glondu.net>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix FTBFS on non-native architectures
+
+@DPATCH@
+diff --git a/Makefile.build b/Makefile.build
+index a5bae4e..c47b688 100644
+--- a/Makefile.build
++++ b/Makefile.build
+@@ -655,7 +655,10 @@ install-library:
+ $(MKDIR) $(FULLCOQLIB)/states
+ $(INSTALLLIB) states/*.coq $(FULLCOQLIB)/states
+ $(MKDIR) $(FULLCOQLIB)/user-contrib
+- $(INSTALLLIB) $(LINKCMO) $(LINKCMX) $(GRAMMARCMA) $(FULLCOQLIB)
++ $(INSTALLLIB) $(LINKCMO) $(GRAMMARCMA) $(FULLCOQLIB)
++ifeq ($(BEST),opt)
++ $(INSTALLLIB) $(LINKCMX) $(FULLCOQLIB)
++endif
+ find . -name \*.cmi -exec $(INSTALLLIB) {} $(FULLCOQLIB) \;
+
+ install-library-light:
+@@ -716,7 +719,7 @@ dev/printers.cma: $(PRINTERSCMO)
+ parsing/grammar.cma: $(GRAMMARCMO)
+ $(SHOW)'Testing $@'
+ @touch test.ml4
+- $(HIDE)$(OCAMLOPT) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
++ $(HIDE)$(OCAMLC) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
+ @rm -f test-grammar test.*
+ $(SHOW)'OCAMLC -a $@'
+ $(HIDE)$(OCAMLC) $(BYTEFLAGS) $(GRAMMARCMO) -linkall -a -o $@