summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2010-10-19 15:42:31 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2010-10-19 15:48:10 +0200
commite942f0c9b2c6be2799f0858a11edaf26e17b18f8 (patch)
treedd5d3e47027e72fae43816ca62ec2b32dadf4f0b
parentd3bc4be4a7aca149529b8cffae63b3c421bf7118 (diff)
debian/rules: make "build" a phony target
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ad1c70ea..3471198a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,6 +37,12 @@ export OCAMLINIT_SED += \
%:
+dh --with ocaml $@
+# There is already a file named "build" in upstream sources, so the
+# above rule is never called. We make it explicitly a phony rule here.
+.PHONY: build
+build:
+ +dh --with ocaml $@
+
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
./configure $(CONFIGUREOPTS)