summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2010-06-03 11:59:03 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2010-07-21 09:51:45 +0200
commitc90511bdca134a941999a9dd2a09b5f1c998c0b7 (patch)
tree47e56fc28e1e1e18ca08d157af7b1e474433fbf8
parent38f3239475df052db4e560191c65144b6905c4fe (diff)
Update packaging according to upstream changes
-rw-r--r--debian/coq.install.in7
-rw-r--r--debian/coq.links.in3
-rwxr-xr-xdebian/rules11
3 files changed, 7 insertions, 14 deletions
diff --git a/debian/coq.install.in b/debian/coq.install.in
index ba265336..f46cd96e 100644
--- a/debian/coq.install.in
+++ b/debian/coq.install.in
@@ -2,14 +2,11 @@ usr/bin/coqc*
usr/bin/coqdep*
usr/bin/coqdoc*
usr/bin/coq_makefile*
-usr/bin/coq-interface*
-usr/bin/coq-parser*
usr/bin/coq-tex*
usr/bin/coqtop*
usr/bin/coqwc*
usr/bin/gallina*
-usr/lib/coq/contrib/micromega/csdpcert
-usr/lib/coq/contrib/interface/vernacrc
+usr/lib/coq/plugins/micromega/csdpcert
usr/lib/coq/tools/coqdoc/coqdoc.css
usr/lib/coq/tools/coqdoc/coqdoc.sty
usr/lib/coq/states/initial.coq
@@ -18,8 +15,6 @@ usr/share/man/man1/coqc*
usr/share/man/man1/coqdep*
usr/share/man/man1/coqdoc*
usr/share/man/man1/coq_makefile*
-usr/share/man/man1/coq-interface*
-usr/share/man/man1/coq-parser*
usr/share/man/man1/coq-tex*
usr/share/man/man1/coqtop*
usr/share/man/man1/coqwc*
diff --git a/debian/coq.links.in b/debian/coq.links.in
index 250c3210..33c64ad9 100644
--- a/debian/coq.links.in
+++ b/debian/coq.links.in
@@ -1,2 +1 @@
-OPT: /usr/share/man/man1/coq-interface.1 /usr/share/man/man1/coq-interface.opt.1
-OPT: /usr/share/man/man1/coq-parser.1 /usr/share/man/man1/coq-parser.opt.1
+OPT: /usr/share/man/man1/coqchk.1 /usr/share/man/man1/coqchk.opt.1 \ No newline at end of file
diff --git a/debian/rules b/debian/rules
index 5a7363fa..fac32b76 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,6 @@
BUILDCACHE := $(wildcard ../coq.cache)
# This has to be exported to make some magic below work.
-export COQTEST_SKIPCOMPLEXITY = true
export CAML_LD_LIBRARY_PATH = $(shell pwd)/kernel/byterun
# Show full commands when building Coq
@@ -19,15 +18,15 @@ include /usr/share/ocaml/ocamlvars.mk
HTMLDOC := doc/stdlib/html/index.html
COQPREF := $(CURDIR)/debian/tmp
-ADDPREF := COQINSTALLPREFIX=$(COQPREF)
+ADDPREF := COQINSTALLPREFIX=$(COQPREF) OLDROOT=
PACKAGES := $(shell dh_listpackages)
-COQ_VERSION := $(shell head -n1 debian/changelog | awk -F'[+() ]' '{print $$3}')
+COQ_VERSION := $(shell dpkg-parsechangelog | sed -n -e 's/~/+/g' -e 's/^Version: \(.*\)-[0-9]\+/\1/p')
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
- --emacslib /usr/share/emacs/site-lisp/coq --reals all --fsets all \
+ --emacslib /usr/share/emacs/site-lisp/coq \
--browser "/usr/bin/x-www-browser %s &" \
--with-doc no --coqrunbyteflags "-dllib -lcoqrun"
@@ -50,7 +49,7 @@ ifeq ($(BUILDCACHE),)
# the default one without -silent (-silent maybe cause buildd to
# timeout because of lack of output)
- $(MAKE) STRIP=true VALIDOPTS="-o -m" check
+ $(MAKE) STRIP=true VALIDOPTS="-o -m" COMPLEXITY= check
$(MAKE) DOC_TARGETS=$(HTMLDOC) $(HTMLDOC)
else
rsync -a --exclude=debian --exclude=.git $(BUILDCACHE)/ .
@@ -64,7 +63,7 @@ override_dh_auto_test:
override_dh_auto_install:
$(MAKE) $(ADDPREF) install
find debian/tmp -regextype posix-awk \
- -regex '.*\.(cm[aoxi]|cmxa|[ao])$$' \
+ -regex '.*\.(cm[xi]|cmxa|[ao])$$' \
>> debian/libcoq-ocaml-dev.install
find debian/tmp -name '*.vo' -printf '%P\n' \
>> debian/coq-theories.install