summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-02-20 13:13:06 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2009-02-20 13:13:06 +0100
commit7696c0afa22fd9d63047a9af2b634cb0e5897d23 (patch)
tree259bffc03804c16b4acb80d7352a57ce6cdcf8c7
parenta426602c408cdf2ec2cc636cc79b9cc68ea238d1 (diff)
Use Debian changelog to determine COQ_VERSION
-rwxr-xr-xdebian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 04a75b29..8b587ea6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,10 +27,8 @@ PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
OFILES := $(patsubst %.in,%,$(wildcard debian/*.in))
-# Beware: -1 is part of upstream version
-COQVERSION := 8.2-1
-
-COQ_ABI := $(COQVERSION)+$(OCAML_ABI)
+COQ_VERSION := $(shell head -n1 debian/changelog | awk -F'[+() ]' '{print $$3}')
+COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
--emacslib /usr/share/emacs/site-lisp/coq --reals all --fsets all \