summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2009-02-19 13:28:17 +0100
committerGravatar Samuel Mimram <smimram@debian.org>2009-02-19 14:04:55 +0100
commit822ee2f2f71d84af35d3adede92a857ce6159b89 (patch)
treedea4ba525830870ac069f8d32a9e949658e0d7ce
parent217a759bdf92847445bddfdf4aa2135930bf5462 (diff)
Use variables from dh-ocaml in rules.
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--debian/coq.dirs.in2
-rw-r--r--debian/coq.install.in2
-rwxr-xr-xdebian/rules15
5 files changed, 15 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 38204324..d2fd8752 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,12 @@
coq (8.2-1+dfsg-1) UNRELEASED; urgency=low
+ [ Stephane Glondu ]
* New Upstream Version
- -- Stephane Glondu <steph@glondu.net> Thu, 19 Feb 2009 13:13:31 +0100
+ [ Samuel Mimram ]
+ * Use variables from dh-ocaml in rules.
+
+ -- Samuel Mimram <smimram@debian.org> Thu, 19 Feb 2009 13:27:14 +0100
coq (8.2~rc2+dfsg-3) experimental; urgency=low
diff --git a/debian/control b/debian/control
index 7e82c7e0..1f0ec103 100644
--- a/debian/control
+++ b/debian/control
@@ -14,6 +14,7 @@ Build-Depends:
debhelper (>= 7),
dpkg-dev (>= 1.13.19),
dpatch,
+ dh-ocaml (>= 0.2),
ocaml-nox,
ocaml-best-compilers,
camlp5,
diff --git a/debian/coq.dirs.in b/debian/coq.dirs.in
index 20f8dc0d..7642db56 100644
--- a/debian/coq.dirs.in
+++ b/debian/coq.dirs.in
@@ -3,4 +3,4 @@ usr/lib/coq/contrib/micromega
usr/share/man/man1
usr/share/pixmaps
usr/share/texmf/tex/latex/misc
-usr/lib/ocaml/@OCamlABI@/stublibs
+@OCamlDllDir@
diff --git a/debian/coq.install.in b/debian/coq.install.in
index 220680e9..4e9eb49a 100644
--- a/debian/coq.install.in
+++ b/debian/coq.install.in
@@ -24,5 +24,5 @@ usr/share/man/man1/coq-tex*
usr/share/man/man1/coqtop*
usr/share/man/man1/coqwc*
usr/share/man/man1/gallina*
-usr/lib/coq/dllcoqrun.so usr/lib/ocaml/@OCamlABI@/stublibs
+usr/lib/coq/dllcoqrun.so @OCamlDllDir@
usr/share/emacs/site-lisp/coqdoc.sty usr/share/texmf/tex/latex/misc/
diff --git a/debian/rules b/debian/rules
index 4c135a31..eede101b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,7 @@ export VERBOSE=1
# We want to use dpatch
include /usr/share/dpatch/dpatch.make
+include /usr/share/ocaml/ocamlvars.mk
HTMLDOC := doc/stdlib/html/index.html
@@ -25,22 +26,20 @@ ADDPREF := COQINSTALLPREFIX=$(COQPREF)
PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
OFILES := $(patsubst %.in,%,$(wildcard debian/*.in))
-OCAMLABI := $(shell ocamlc -version)
# Beware: -1 is part of upstream version
COQVERSION := 8.2-1
-COQABI := $(COQVERSION)+$(OCAMLABI)
+COQ_ABI := $(COQVERSION)+$(OCAML_ABI)
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
--emacslib /usr/share/emacs/site-lisp/coq --reals all --fsets all \
--browser "/usr/bin/x-www-browser %s &" \
--with-doc no --coqrunbyteflags "-dllib -lcoqrun"
-OCAMLINITSED := -e 's/@OCamlABI@/$(OCAMLABI)/g' -e '/^\#/d'
-OCAMLOPT := $(wildcard /usr/bin/ocamlopt*)
+OCAMLINITSED := -e 's%@OCamlDllDir@%$(OCAML_DLL_DIR)%g' -e '/^\#/d'
-ifneq ($(OCAMLOPT),)
+ifneq ($(OCAML_OPT_ARCH),)
# CONFIGUREOPTS += -opt
OCAMLINITSED += -e 's/^OPT: //'
else
@@ -84,11 +83,11 @@ install-stamp: build-stamp
cp debian/coq.xpm debian/coqide/usr/share/pixmaps/coqide.xpm
cp debian/coqide.desktop debian/coqide/usr/share/applications
cp -r doc/stdlib/html debian/coq-theories/usr/share/doc/coq-theories/
- echo "$(COQABI)" > debian/coq/usr/lib/coq/abi
+ echo "$(COQ_ABI)" > debian/coq/usr/lib/coq/abi
dh install --after dh_install
for u in $(PACKAGES); do \
- echo 'F:OCamlABI=$(OCAMLABI)' >> debian/$$u.substvars; \
- echo 'F:CoqABI=$(COQABI)' >> debian/$$u.substvars; \
+ echo 'F:OCamlABI=$(OCAML_ABI)' >> debian/$$u.substvars; \
+ echo 'F:CoqABI=$(COQ_ABI)' >> debian/$$u.substvars; \
done
touch $@