summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-02-01 07:47:14 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2009-02-01 11:10:06 +0100
commitc00af6d8c1ace1a117dbf4bfbb2dfbc0c7679e1a (patch)
tree274948084ba2245d4cb3ddd45d496a9fa7b76b49
parent277eee0a26f50107a302957a9dff7119afae84c2 (diff)
Add coq-${F:CoqABI} virtual package
Rationale: *.vo files depend on the version of Coq used to compile them. This virtual package will be useful for other packages providing *.vo (e.g. why, ssreflect).
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules9
2 files changed, 9 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index b3dadb56..5a256345 100644
--- a/debian/control
+++ b/debian/control
@@ -32,6 +32,7 @@ Depends:
ocaml-base-nox-${F:OCamlABI},
coq-theories (= ${source:Version}),
emacsen-common
+Provides: coq-${F:CoqABI}
Recommends: coqide | proofgeneral-coq
Suggests:
ocaml-nox,
@@ -70,7 +71,7 @@ Description: proof assistant for higher-order logic (gtk interface)
Package: coq-theories
Architecture: all
-Depends: ${misc:Depends}
+Depends: coq-${F:CoqABI}, ${misc:Depends}
Recommends: coq (>= 8.0)
Conflicts: coq-doc (<= 8.0pl1.0-2), coq-libs
Replaces: coq-libs
diff --git a/debian/rules b/debian/rules
index 4e502a8f..e0e71616 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,7 +22,8 @@ HTMLDOC := doc/stdlib/html/index.html
COQPREF := $(CURDIR)/debian/tmp
ADDPREF := COQINSTALLPREFIX=$(COQPREF)
-ARCH_PKGS := coq coqide libcoq-ocaml-dev
+COQABI := 8.2
+PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
OFILES := $(patsubst %.in,%,$(wildcard debian/*.in))
OCAMLABI := $(shell ocamlc -version)
@@ -79,7 +80,12 @@ install-stamp: build-stamp
cp debian/coq.xpm debian/coqide/usr/share/pixmaps/coqide.xpm
cp debian/coqide.desktop debian/coqide/usr/share/applications
cp -r doc/stdlib/html debian/coq-theories/usr/share/doc/coq-theories/
+ echo "$(COQABI)" > debian/coq/usr/lib/coq/abi
dh install --after dh_install
+ for u in $(PACKAGES); do \
+ echo 'F:OCamlABI=$(OCAMLABI)' >> debian/$$u.substvars; \
+ echo 'F:CoqABI=$(COQABI)' >> debian/$$u.substvars; \
+ done
touch $@
clean: unpatch
@@ -90,7 +96,6 @@ binary-indep: install-stamp
dh $@
binary-arch: install-stamp
- for u in $(ARCH_PKGS); do echo 'F:OCamlABI=$(OCAMLABI)' >> debian/$$u.substvars; done
dh $@
binary: binary-indep binary-arch