summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2009-02-20 15:26:56 +0100
committerGravatar Samuel Mimram <smimram@debian.org>2009-02-20 15:26:56 +0100
commit76018532b0a90f0d9951589d277d95af85e4cd2a (patch)
tree16e2151d60787b07eda8017ef2bd266a0a0e30e6
parent3e278fa6f5b2c304165e081a325ee054db4fed97 (diff)
parent9603746faaccf85ee2e95570d2a0fb0a74a2aa1b (diff)
Merge branch 'master' of git+ssh://git.debian.org//git/pkg-ocaml-maint/packages/coq
-rw-r--r--debian/changelog11
-rw-r--r--debian/control1
-rw-r--r--debian/coqvars.mk.in (renamed from debian/coqvars.mk)4
-rw-r--r--debian/patches/00list0
-rwxr-xr-xdebian/rules34
5 files changed, 15 insertions, 35 deletions
diff --git a/debian/changelog b/debian/changelog
index 9bf26525..61566020 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,13 +1,12 @@
coq (8.2-1+dfsg-1) UNRELEASED; urgency=low
- [ Stephane Glondu ]
* New Upstream Version
+ * Use variables and ocamlinit rule from dh-ocaml in rules
+ * Added coqvars.mk helper for coq-related packages, and remove
+ /usr/lib/coq/abi (its contents is now it the COQ_ABI variable)
+ * Remove dependency on dpatch
- [ Samuel Mimram ]
- * Use variables from dh-ocaml in rules.
- * Added coqvars.mk helper for coq-related packages.
-
- -- Samuel Mimram <smimram@debian.org> Thu, 19 Feb 2009 13:54:38 +0100
+ -- Stephane Glondu <steph@glondu.net> Fri, 20 Feb 2009 15:21:15 +0100
coq (8.2~rc2+dfsg-3) experimental; urgency=low
diff --git a/debian/control b/debian/control
index 1f0ec103..805d5879 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,6 @@ Standards-Version: 3.8.0
Build-Depends:
debhelper (>= 7),
dpkg-dev (>= 1.13.19),
- dpatch,
dh-ocaml (>= 0.2),
ocaml-nox,
ocaml-best-compilers,
diff --git a/debian/coqvars.mk b/debian/coqvars.mk.in
index 3cf8fe08..efbbd248 100644
--- a/debian/coqvars.mk
+++ b/debian/coqvars.mk.in
@@ -1,8 +1,8 @@
# Current coq version
-COQ_VERSION ?= $(shell /usr/bin/coqc --version | grep version | sed 's/^.*version \(.*\) ([^)]*)$/\1/')
+COQ_VERSION ?= @CoqVersion@
# Current coq ABI
-COQ_ABI ?= $(shell cat /usr/lib/coq/abi)
+COQ_ABI ?= @CoqABI@
# Standard library path
COQ_STDLIB_DIR ?= $(shell /usr/bin/coqc -where)
diff --git a/debian/patches/00list b/debian/patches/00list
deleted file mode 100644
index e69de29b..00000000
--- a/debian/patches/00list
+++ /dev/null
diff --git a/debian/rules b/debian/rules
index 04a75b29..014134a7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,9 +14,7 @@ export CAML_LD_LIBRARY_PATH = $(shell pwd)/kernel/byterun
# Show full commands when building Coq
export VERBOSE=1
-# We want to use dpatch
-include /usr/share/dpatch/dpatch.make
-include /usr/share/ocaml/ocamlvars.mk
+include /usr/share/ocaml/ocamlinit.mk
HTMLDOC := doc/stdlib/html/index.html
@@ -25,34 +23,20 @@ ADDPREF := COQINSTALLPREFIX=$(COQPREF)
PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
-OFILES := $(patsubst %.in,%,$(wildcard debian/*.in))
-
-# Beware: -1 is part of upstream version
-COQVERSION := 8.2-1
-
-COQ_ABI := $(COQVERSION)+$(OCAML_ABI)
+COQ_VERSION := $(shell head -n1 debian/changelog | awk -F'[+() ]' '{print $$3}')
+COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
--emacslib /usr/share/emacs/site-lisp/coq --reals all --fsets all \
--browser "/usr/bin/x-www-browser %s &" \
--with-doc no --coqrunbyteflags "-dllib -lcoqrun"
-OCAMLINITSED := -e 's%@OCamlDllDir@%$(OCAML_DLL_DIR)%g' -e '/^\#/d'
-
-ifneq ($(OCAML_OPT_ARCH),)
- # CONFIGUREOPTS += -opt
- OCAMLINITSED += -e 's/^OPT: //'
-else
- OCAMLINITSED += -e '/^OPT: /d'
-endif
-
-ocamlinit: ocamlinit-stamp
-ocamlinit-stamp:
- for f in $(OFILES); do sed $(OCAMLINITSED) $$f.in > $$f; done
- touch $@
+OCAMLINIT_SED += \
+ -e 's%@CoqVersion@%$(COQ_VERSION)%' \
+ -e 's%@CoqABI@%$(COQ_ABI)%'
configure: configure-stamp
-configure-stamp: patch-stamp ocamlinit-stamp
+configure-stamp: ocamlinit-stamp
dh build --before dh_auto_configure
./configure $(CONFIGUREOPTS)
touch $@
@@ -83,7 +67,6 @@ install-stamp: build-stamp
cp debian/coq.xpm debian/coqide/usr/share/pixmaps/coqide.xpm
cp debian/coqide.desktop debian/coqide/usr/share/applications
cp -r doc/stdlib/html debian/coq-theories/usr/share/doc/coq-theories/
- echo "$(COQ_ABI)" > debian/coq/usr/lib/coq/abi
cp debian/coqvars.mk debian/coq/usr/share/coq/
dh install --after dh_install
for u in $(PACKAGES); do \
@@ -92,9 +75,8 @@ install-stamp: build-stamp
done
touch $@
-clean: unpatch
+clean: ocamlinit-clean
dh $@
- rm -f $(OFILES)
binary-indep: install-stamp
dh $@