summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-02-20 13:17:59 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2009-02-20 15:08:04 +0100
commit72851683d176c05e44c56fea593c73e4691d3450 (patch)
tree2d5d53610063277eeab71b7bbe50a318487d3442
parent7696c0afa22fd9d63047a9af2b634cb0e5897d23 (diff)
Use ocamlinit.mk
-rwxr-xr-xdebian/rules21
1 files changed, 2 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index 8b587ea6..6d55d2c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ export VERBOSE=1
# We want to use dpatch
include /usr/share/dpatch/dpatch.make
-include /usr/share/ocaml/ocamlvars.mk
+include /usr/share/ocaml/ocamlinit.mk
HTMLDOC := doc/stdlib/html/index.html
@@ -25,8 +25,6 @@ ADDPREF := COQINSTALLPREFIX=$(COQPREF)
PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
-OFILES := $(patsubst %.in,%,$(wildcard debian/*.in))
-
COQ_VERSION := $(shell head -n1 debian/changelog | awk -F'[+() ]' '{print $$3}')
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
@@ -35,20 +33,6 @@ CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
--browser "/usr/bin/x-www-browser %s &" \
--with-doc no --coqrunbyteflags "-dllib -lcoqrun"
-OCAMLINITSED := -e 's%@OCamlDllDir@%$(OCAML_DLL_DIR)%g' -e '/^\#/d'
-
-ifneq ($(OCAML_OPT_ARCH),)
- # CONFIGUREOPTS += -opt
- OCAMLINITSED += -e 's/^OPT: //'
-else
- OCAMLINITSED += -e '/^OPT: /d'
-endif
-
-ocamlinit: ocamlinit-stamp
-ocamlinit-stamp:
- for f in $(OFILES); do sed $(OCAMLINITSED) $$f.in > $$f; done
- touch $@
-
configure: configure-stamp
configure-stamp: patch-stamp ocamlinit-stamp
dh build --before dh_auto_configure
@@ -90,9 +74,8 @@ install-stamp: build-stamp
done
touch $@
-clean: unpatch
+clean: unpatch ocamlinit-clean
dh $@
- rm -f $(OFILES)
binary-indep: install-stamp
dh $@