summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2008-07-28 17:10:05 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2008-07-28 17:13:41 +0200
commit284e68ace18db77fed501d3d64ff3cb54d44c02c (patch)
tree39f1b8dc4ebaae06f501326e1e720a6e4dfa67ad
parentcd46e5dd680be14a5f5401cfc00af3a7d2ad8847 (diff)
Create bin/ in configure instead of clean
...avoiding problems with clean run as root
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 5151c911..177270d0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,6 +20,8 @@ CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man --emacslib /
configure: configure-stamp
configure-stamp:
dh_testdir
+ # git doesn't handle empty directories, so we create them here
+ -mkdir bin
if [ -e /usr/bin/ocamlc.opt ]; \
then \
./configure -opt $(CONFIGUREOPTS); \
@@ -67,8 +69,6 @@ clean: unpatch
rm -f dev/ocamldebug-v7
rm -f ide/undo.mli glob.dump
rm -f test-suite/modules/*.vo
- # git doesn't handle empty directories, so we create them here
- -mkdir bin
dh_clean