summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2008-10-16 13:39:34 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2008-10-16 13:39:34 +0200
commit3e6a1167fd397f2c72b48315e5d82f6c7e24703f (patch)
tree5778212e4dee21b53d8626e05e3fef0387ad3885
parente9ca8bf54ae638fcab7fac39feec5ca047578d07 (diff)
Define substvars more appropriately
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 19bd688d..58ad7e19 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,7 +42,6 @@ configure: configure-stamp
configure-stamp: patch-stamp ocamlinit-stamp
dh build --before dh_auto_configure
./configure $(CONFIGUREOPTS)
- echo 'F:OCamlABI="$(OCAMLABI)"' > debian/substvars
touch $@
build: build-stamp
@@ -76,6 +75,7 @@ binary-indep: install-stamp
dh $@
binary-arch: install-stamp
+ for u in coq coqide; do echo 'F:OCamlABI=$(OCAMLABI)' >> debian/$$u.substvars; done
dh $@
binary: binary-indep binary-arch