summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2005-03-25 12:37:44 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2005-03-25 12:37:44 +0000
commit14231a6b9f78637e23885e9854254b84259c1149 (patch)
tree3d80027bb57196f2672393bc6eb11274deae9fad
parent3b182903454caa27cd34fc38c594970a800dc9a1 (diff)
Updated to OCaml 3.08.3 + small fixes.
-rw-r--r--debian/changelog13
-rw-r--r--debian/control6
-rw-r--r--debian/coq-libs.install1
-rw-r--r--debian/coq.dirs1
-rwxr-xr-xdebian/rules17
5 files changed, 22 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index dca117be..f2a5d0c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+coq (8.0pl2-2) unstable; urgency=medium
+
+ * Rebuilding with OCaml 3.08.3 is necessary because of the former dependency
+ on ocaml-base-nox-3.08.
+ * Removed the dependency on ocaml-base-nox-3.08 since ocamlrun does not seem
+ to be necessary, even on non-native archs.
+ * Cleaner handling of -arch and -indep targets.
+ * Added utf8.v in coq and utf8.vo to coq-libs since utf8 can be useful for
+ non-coqide users too.
+ * Using dh_desktop to register .desktop files.
+
+ -- Samuel Mimram <smimram@debian.org> Tue, 22 Mar 2005 17:40:08 +0100
+
coq (8.0pl2-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index 25695824..d15b63d8 100644
--- a/debian/control
+++ b/debian/control
@@ -4,11 +4,11 @@ Priority: optional
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Uploaders: Ralf Treinen <treinen@debian.org>, Sven Luther <luther@debian.org>, Jerome Marant <jerome@debian.org>, Remi Vanicat <vanicat@debian.org>, Stefano Zacchiroli <zack@debian.org>, Samuel Mimram <smimram@debian.org>
Standards-Version: 3.6.1.1
-Build-Depends: debhelper (>= 4.0.0), dpatch, ocaml-nox-3.08, ocaml-nox (>= 3.08.2), ocaml-best-compilers, liblablgtk2-ocaml-dev (>= 2.4.0)
+Build-Depends: debhelper (>= 4.0.0), dpatch, ocaml-nox (>= 3.08.2), ocaml-best-compilers, liblablgtk2-ocaml-dev (>= 2.4.0)
Package: coq
Architecture: any
-Depends: ${shlibs:Depends}, ${ocaml:Runtime}, coq-libs (= ${Source-Version})
+Depends: ${shlibs:Depends}, coq-libs (= ${Source-Version})
Recommends: coq-doc, coqide | proofgeneral-coq
Suggests: ocaml-3.08, proofgeneral-coq, ledit, cle
Description: proof assistant for higher-order logic (toplevel and compiler)
@@ -26,7 +26,7 @@ Description: proof assistant for higher-order logic (toplevel and compiler)
Package: coqide
Architecture: any
-Depends: ${shlibs:Depends}, ${ocaml:Runtime}, coq (>= 8.0), liblablgtk2-ocaml (>= 2.4.0)
+Depends: ${shlibs:Depends}, coq (>= 8.0), liblablgtk2-ocaml (>= 2.4.0)
Description: proof assistant for higher-order logic (gtk interface)
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
diff --git a/debian/coq-libs.install b/debian/coq-libs.install
index a2671191..c721f0c8 100644
--- a/debian/coq-libs.install
+++ b/debian/coq-libs.install
@@ -1,3 +1,4 @@
usr/lib/coq/contrib
usr/lib/coq/states
usr/lib/coq/theories
+usr/lib/coq/ide/utf8.vo usr/lib/coq
diff --git a/debian/coq.dirs b/debian/coq.dirs
index 1166b157..719fd80d 100644
--- a/debian/coq.dirs
+++ b/debian/coq.dirs
@@ -3,3 +3,4 @@ usr/lib
usr/lib/coq
usr/share/man/man1
usr/share/pixmaps
+ide/utf8.v
diff --git a/debian/rules b/debian/rules
index 9c65c9b3..872edde4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -102,30 +102,21 @@ binary-common:
dh_installemacsen
dh_installman
dh_installchangelogs CHANGES
+ dh_desktop
dh_link
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
binary-indep: build install
$(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
- dh_gencontrol -pcoq-libs
- dh_gencontrol -pcoq7-libs
- dh_md5sums -i
- dh_builddeb -i
binary-arch: build install
$(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
- if [ -e opt-stamp ]; then \
- dh_gencontrol -pcoq -u-Vocaml:Runtime=""; \
- dh_gencontrol -pcoqide -u-Vocaml:Runtime=""; \
- else \
- dh_gencontrol -pcoq -u-Vocaml:Runtime="ocaml-base-nox-3.08"; \
- dh_gencontrol -pcoqide -u-Vocaml:Runtime="ocaml-base-nox-3.08"; \
- fi
- dh_md5sums -s
- dh_builddeb -s
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary-common binary install configure