summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-18 23:53:48 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-18 23:53:48 +0000
commit19ee9e6a99e8f033805c45cb7b47d2b84e706c46 (patch)
tree936fb2ec3e883c97a350c7cba7278f0480796e43
parent12ac9238f46cba4693724082849df258db73ee2e (diff)
Depend on ocaml-base-nox if coq is compiled in bytecode.
-rw-r--r--debian/changelog7
-rw-r--r--debian/control12
-rwxr-xr-xdebian/rules31
3 files changed, 33 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index ace7314a..c3165eb3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+coq (8.0pl1-3) unstable; urgency=medium
+
+ * Added a dependency to ocaml-base-nox when coq is compiled in bytecode.
+ * Enhanced the short descriptions of the packages.
+
+ -- Samuel Mimram <samuel.mimram@ens-lyon.org> Tue, 17 Aug 2004 20:54:25 +0200
+
coq (8.0pl1-2) unstable; urgency=medium
* Changed section to math.
diff --git a/debian/control b/debian/control
index 1bec4341..2ca8c21b 100644
--- a/debian/control
+++ b/debian/control
@@ -8,10 +8,10 @@ Build-Depends: debhelper (>= 4.0.0), ocaml-3.08, ocaml-best-compilers, liblablgt
Package: coq
Architecture: any
-Depends: ${shlibs:Depends}, coq-libs
+Depends: ${shlibs:Depends}, ${ocaml:Runtime}, coq-libs
Suggests: ocaml-3.08, proofgeneral-coq, ledit, cle
Recommends: coq-doc, coqide | proofgeneral-coq
-Description: Proof assistant for higher-order logic
+Description: Proof assistant for higher-order logic (toplevel and compiler)
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
specification. It is developed using Objective Caml and Camlp4.
@@ -26,8 +26,8 @@ Description: Proof assistant for higher-order logic
Package: coqide
Architecture: any
-Depends: coq (>= 8.0), liblablgtk2-ocaml (>= 2.4.0), ${shlibs:Depends}
-Description: Proof assistant for higher-order logic
+Depends: ${shlibs:Depends}, coq (>= 8.0), liblablgtk2-ocaml (>= 2.4.0)
+Description: Proof assistant for higher-order logic (gtk interface)
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
specification. It is developed using Objective Caml and Camlp4.
@@ -40,7 +40,7 @@ Package: coq-libs
Architecture: any
Recommends: coq (>= 8.0)
Conflicts: coq (<< 8.0)
-Description: Proof assistant for higher-order logic
+Description: Proof assistant for higher-order logic (theories)
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
specification. It is developed using Objective Caml and Camlp4.
@@ -52,7 +52,7 @@ Description: Proof assistant for higher-order logic
Package: coq7-libs
Architecture: any
Recommends: coq (>= 8.0)
-Description: Proof assistant for higher-order logic
+Description: Proof assistant for higher-order logic (Coq 7 theories)
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
specification. It is developed using Objective Caml and Camlp4.
diff --git a/debian/rules b/debian/rules
index 8e927795..fa8d268d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,23 +24,25 @@ build-stamp:
touch test-suite/success/debian.v8
if grep -q BEST=opt config/Makefile; \
then \
- $(MAKE) check \
- || (echo WARNING: NATIVE CODE COMPILATION FAILED \
- && echo Trying to build coq in bytecode instead \
- && $(MAKE) archclean clean \
- && touch test-suite/success/debian.v8 \
- && $(MAKE) BEST=byte HASCOQIDE=byte check \
- && echo NATIVE CODE COMPILATION FAILED \
- && echo Coq was built in bytecode instead); \
+ $(MAKE) check \
+ || (echo WARNING: NATIVE CODE COMPILATION FAILED \
+ && echo Trying to build coq in bytecode instead \
+ && $(MAKE) archclean clean \
+ && touch test-suite/success/debian.v8 \
+ && $(MAKE) BEST=byte HASCOQIDE=byte check \
+ && touch byte-stamp \
+ && echo NATIVE CODE COMPILATION FAILED \
+ && echo Coq was built in bytecode instead); \
else \
- $(MAKE) check; \
+ $(MAKE) check; \
+ touch byte-stamp; \
fi
touch build-stamp
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp
+ rm -f build-stamp configure-stamp byte-stamp
-$(MAKE) clean
-$(MAKE) archclean
@@ -85,7 +87,14 @@ binary-arch: build install
dh_fixperms
dh_installdeb
dh_shlibdeps
- dh_gencontrol
+ if [ -e byte-stamp ]; then \
+ dh_gencontrol -pcoq -u-Vocaml:Runtime="ocaml-base-nox"; \
+ else \
+ dh_gencontrol -pcoq -u-Vocaml:Runtime=""; \
+ fi
+ dh_gencontrol -pcoqide
+ dh_gencontrol -pcoq-libs
+ dh_gencontrol -pcoq7-libs
dh_md5sums
dh_builddeb