summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2007-02-15 13:02:39 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2007-02-15 13:02:39 +0000
commit4d9badb29a176d1feb8ae8da287b3e2f2d1afe36 (patch)
tree6dd216f2970ce45f5645cb094267ddc4b5731c9f
parentd96021d8572d4e16facf14136bac604597deefba (diff)
Correctly detect the presence of ocamlopt.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/configure.dpatch19
3 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 63d6933f..375de7f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+coq (8.1+dfsg-2) UNRELEASED; urgency=low
+
+ * Added configure.dpatch for the configure to correctly detect whether
+ ocamlopt is present or not.
+
+ -- Samuel Mimram <smimram@debian.org> Thu, 15 Feb 2007 13:00:45 +0000
+
coq (8.1+dfsg-1) experimental; urgency=low
* New upstream release.
diff --git a/debian/patches/00list b/debian/patches/00list
index 8c069e14..7f4a29f0 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -2,3 +2,4 @@ coqdoc_stdlib
browser
makefile
no-complexity-test
+configure
diff --git a/debian/patches/configure.dpatch b/debian/patches/configure.dpatch
new file mode 100755
index 00000000..db3ef2a5
--- /dev/null
+++ b/debian/patches/configure.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## configure.dpatch by Pierre Letouzey <pierre.letouzey@pps.jussieu.fr>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Correctly detect whether ocamlopt is present or not.
+
+@DPATCH@
+diff -urNad coq-8.1+dfsg~/configure coq-8.1+dfsg/configure
+--- coq-8.1+dfsg~/configure 2007-02-10 08:32:28.000000000 +0000
++++ coq-8.1+dfsg/configure 2007-02-15 12:58:56.000000000 +0000
+@@ -340,7 +340,7 @@
+ # do we have a native compiler: test of ocamlopt and its version
+
+ if [ "$best_compiler" = "opt" ] ; then
+- if test -e `which "$nativecamlc"` ; then
++ if test -e "`which $nativecamlc`" ; then
+ CAMLOPTVERSION=`"$nativecamlc" -v | sed -n -e 's|.*version* *\(.*\)$|\1|p' `
+ if [ "$CAMLOPTVERSION" != "$CAMLVERSION" ] ; then
+ echo "native and bytecode compilers do not have the same version!"; fi