summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-19 14:02:47 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-19 14:02:47 +0000
commit74da2b554fffaff54d7a473b4bfcb6d5a6e430d1 (patch)
tree97c9db981a66589821e665de7507e89b387a1c77
parent19ee9e6a99e8f033805c45cb7b47d2b84e706c46 (diff)
Versionned the dependency to ocaml-base-nox, added enhanced manpages.
-rw-r--r--debian/changelog1
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules34
3 files changed, 24 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index c3165eb3..c50dac73 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
coq (8.0pl1-3) unstable; urgency=medium
* Added a dependency to ocaml-base-nox when coq is compiled in bytecode.
+ * Added enhaced manpages.
* Enhanced the short descriptions of the packages.
-- Samuel Mimram <samuel.mimram@ens-lyon.org> Tue, 17 Aug 2004 20:54:25 +0200
diff --git a/debian/docs b/debian/docs
index 62998f27..297170db 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,3 +1,2 @@
README
CREDITS
-CHANGES
diff --git a/debian/rules b/debian/rules
index fa8d268d..9f88bf6d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,25 +24,24 @@ build-stamp:
touch test-suite/success/debian.v8
if grep -q BEST=opt config/Makefile; \
then \
- $(MAKE) check \
+ ($(MAKE) check \
+ && touch opt-stamp) \
|| (echo WARNING: NATIVE CODE COMPILATION FAILED \
&& echo Trying to build coq in bytecode instead \
&& $(MAKE) archclean clean \
&& touch test-suite/success/debian.v8 \
&& $(MAKE) BEST=byte HASCOQIDE=byte check \
- && touch byte-stamp \
&& echo NATIVE CODE COMPILATION FAILED \
&& echo Coq was built in bytecode instead); \
else \
- $(MAKE) check; \
- touch byte-stamp; \
+ $(MAKE) BEST=byte HASCOQIDE=byte check; \
fi
touch build-stamp
clean:
dh_testdir
dh_testroot
- rm -f build-stamp configure-stamp byte-stamp
+ rm -f build-stamp configure-stamp opt-stamp
-$(MAKE) clean
-$(MAKE) archclean
@@ -58,7 +57,11 @@ install: build
dh_clean -k
dh_installdirs
- $(MAKE) $(ADDPREF) install || $(MAKE) BEST=byte HASCOQIDE=byte $(ADDPREF) install
+ if [ -e opt-stamp ]; then \
+ $(MAKE) $(ADDPREF) install; \
+ else \
+ $(MAKE) BEST=byte HASCOQIDE=byte $(ADDPREF) install; \
+ fi
-for i in $(COQPREF)/usr/bin/*.opt; do \
echo "Stripping: $$i"; \
@@ -69,10 +72,19 @@ install: build
dh_install --sourcedir=$(COQPREF)
- cp debian/coq/usr/share/man/man1/coq-interface.1 debian/coq/usr/share/man/man1/coq-interface.opt.1
+ #TODO: change lib_ide to /usr/share/coqide
+ cp ide/index_urls.txt debian/coqide/usr/lib/coq/ide/index_urls.txt
+ if [ -e opt-stamp ]; then \
+ cp debian/coq/usr/share/man/man1/coq-interface.1 debian/coq/usr/share/man/man1/coq-interface.opt.1; \
+ cp debian/coqide.1 debian/coqide/usr/share/man/man1/coqide.opt.1; \
+ fi
cp debian/coqide.1 debian/coqide/usr/share/man/man1/coqide.1
cp debian/coqide.1 debian/coqide/usr/share/man/man1/coqide.byte.1
- cp debian/coqide.1 debian/coqide/usr/share/man/man1/coqide.opt.1
+ cp debian/coqc.1 debian/coq/usr/share/man/man1/coqc.1
+ cp debian/coq-interface.1 debian/coq/usr/share/man/man1/coq-interface.1
+ cp debian/coq_makefile.1 debian/coq/usr/share/man/man1/coq_makefile.1
+ cp debian/coqmktop.1 debian/coq/usr/share/man/man1/coqmktop.1
+ cp debian/coqtop.1 debian/coq/usr/share/man/man1/coqtop.1
binary-indep: build install
@@ -87,10 +99,10 @@ binary-arch: build install
dh_fixperms
dh_installdeb
dh_shlibdeps
- if [ -e byte-stamp ]; then \
- dh_gencontrol -pcoq -u-Vocaml:Runtime="ocaml-base-nox"; \
- else \
+ if [ -e opt-stamp ]; then \
dh_gencontrol -pcoq -u-Vocaml:Runtime=""; \
+ else \
+ dh_gencontrol -pcoq -u-Vocaml:Runtime="ocaml-base-nox-3.08"; \
fi
dh_gencontrol -pcoqide
dh_gencontrol -pcoq-libs