summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
Diffstat (limited to 'test')
-rw-r--r--test/regression/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 2af20e6..cc8684c 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -1,7 +1,8 @@
include ../../Makefile.config
CCOMP=../../ccomp
-CCOMPFLAGS=-stdlib ../../runtime -dparse -dclight -dasm -fall-extensions
+CCOMPFLAGS=-stdlib ../../runtime -dparse -dclight -dasm \
+ -fstruct-passing -fstruct-assign -fbitfields
LIBS=$(LIBMATH)
@@ -30,7 +31,7 @@ clean:
rm -f *.compcert
rm -f *.parsed.c *.light.c *.s *.o *~
-test_compcert:
+test:
@for i in $(TESTS); do \
if ./$$i.compcert | cmp -s - Results/$$i; \
then echo "$$i: passed"; \