summaryrefslogtreecommitdiff
path: root/test/c
diff options
context:
space:
mode:
Diffstat (limited to 'test/c')
-rw-r--r--test/c/Makefile9
-rw-r--r--test/c/knucleotide.c4
-rw-r--r--test/c/mandelbrot.c4
3 files changed, 4 insertions, 13 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 8896934..3f4ea40 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -1,8 +1,7 @@
CCOMP=../../ccomp
-CCOMPFLAGS=-dump-c -I../lib
+CCOMPFLAGS=-stdlib ../../runtime -dclight -dasm
CC=gcc -arch ppc
-
CFLAGS=-O1 -Wall
LIBS=
@@ -20,11 +19,11 @@ all: $(PROGS:%=%.compcert)
all_gcc: $(PROGS:%=%.gcc)
-%.compcert: %.s
- $(CC) $(CFLAGS) -o $*.compcert $*.s ../lib/libcompcert.a $(LIBS)
+%.compcert: %.c $(CCOMP)
+ $(CCOMP) $(CCOMPFLAGS) -o $*.compcert $*.c $(LIBS)
%.s: %.c ../../ccomp
- $(CCOMP) $(CCOMPFLAGS) $*.c
+ $(CCOMP) $(CCOMPFLAGS) -S $*.c
%.gcc: %.c
$(CC) $(CFLAGS) -o $*.gcc $*.c $(LIBS)
diff --git a/test/c/knucleotide.c b/test/c/knucleotide.c
index 955af7f..f743892 100644
--- a/test/c/knucleotide.c
+++ b/test/c/knucleotide.c
@@ -8,11 +8,7 @@
http://cvs.alioth.debian.org/cgi-bin/cvsweb.cgi/shootout/bench/Include/?cvsroot=shootout
*/
-#ifdef __COMPCERT__
-#include <compcert_stdio.h>
-#else
#include <stdio.h>
-#endif
#include <string.h>
#include <ctype.h>
#include <stdlib.h>
diff --git a/test/c/mandelbrot.c b/test/c/mandelbrot.c
index f4c0db1..93aa8ac 100644
--- a/test/c/mandelbrot.c
+++ b/test/c/mandelbrot.c
@@ -10,11 +10,7 @@
compile flags: -O3 -ffast-math -march=pentium4 -funroll-loops
*/
-#ifdef __COMPCERT__
-#include <compcert_stdio.h>
-#else
#include <stdio.h>
-#endif
#include <stdlib.h>
int main (int argc, char **argv)