summaryrefslogtreecommitdiff
path: root/extraction
diff options
context:
space:
mode:
Diffstat (limited to 'extraction')
-rw-r--r--extraction/Makefile12
-rw-r--r--extraction/extraction.v12
2 files changed, 24 insertions, 0 deletions
diff --git a/extraction/Makefile b/extraction/Makefile
index 513577c..5729642 100644
--- a/extraction/Makefile
+++ b/extraction/Makefile
@@ -1,3 +1,15 @@
+#######################################################################
+# #
+# The Compcert verified compiler #
+# #
+# Xavier Leroy, INRIA Paris-Rocquencourt #
+# #
+# Copyright Institut National de Recherche en Informatique et en #
+# Automatique. All rights reserved. This file is distributed #
+# under the terms of the INRIA Non-Commercial License Agreement. #
+# #
+#######################################################################
+
include ../Makefile.config
FILES=\
diff --git a/extraction/extraction.v b/extraction/extraction.v
index 22df593..fc2920e 100644
--- a/extraction/extraction.v
+++ b/extraction/extraction.v
@@ -1,3 +1,15 @@
+(* *********************************************************************)
+(* *)
+(* The Compcert verified compiler *)
+(* *)
+(* Xavier Leroy, INRIA Paris-Rocquencourt *)
+(* *)
+(* Copyright Institut National de Recherche en Informatique et en *)
+(* Automatique. All rights reserved. This file is distributed *)
+(* under the terms of the INRIA Non-Commercial License Agreement. *)
+(* *)
+(* *********************************************************************)
+
Require Iteration.
Require Floats.
Require RTLgen.