summaryrefslogtreecommitdiff
path: root/backend/InterfGraph.v
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
commit3ffda353b0d92ccd0ff3693ad0be81531c3c0537 (patch)
tree9a07da4e83919d763086e379de161fd4cfe8ab02 /backend/InterfGraph.v
parent06c55ab8fa4c0bf59479faf03d30a51c780da36e (diff)
Updated for Coq 8.3pl1. Some cleanups in test/*/Makefile.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1597 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'backend/InterfGraph.v')
-rw-r--r--backend/InterfGraph.v4
1 files changed, 2 insertions, 2 deletions
diff --git a/backend/InterfGraph.v b/backend/InterfGraph.v
index a73e7d7..ec64e99 100644
--- a/backend/InterfGraph.v
+++ b/backend/InterfGraph.v
@@ -243,7 +243,7 @@ Proof.
apply Regset.add_2; apply Regset.add_2; tauto.
intros. rewrite SetRegReg.fold_1. apply H.
- intuition. left. apply SetRegReg.elements_1. auto.
+ intuition.
Qed.
Lemma in_setregreg_fold':
@@ -276,7 +276,7 @@ Proof.
apply Regset.add_2; auto.
intros. rewrite SetRegMreg.fold_1. apply H with mr2.
- intuition. left. apply SetRegMreg.elements_1. auto.
+ intuition.
Qed.
Lemma all_interf_regs_correct_1: