diff options
author | xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e> | 2011-03-09 13:35:00 +0000 |
---|---|---|
committer | xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e> | 2011-03-09 13:35:00 +0000 |
commit | 3ffda353b0d92ccd0ff3693ad0be81531c3c0537 (patch) | |
tree | 9a07da4e83919d763086e379de161fd4cfe8ab02 /arm/Op.v | |
parent | 06c55ab8fa4c0bf59479faf03d30a51c780da36e (diff) |
Updated for Coq 8.3pl1. Some cleanups in test/*/Makefile.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1597 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'arm/Op.v')
-rw-r--r-- | arm/Op.v | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -128,6 +128,7 @@ Inductive addressing: Type := Definition eq_shift (x y: shift): {x=y} + {x<>y}. Proof. + revert x y. generalize Int.eq_dec; intro. assert (forall (x y: shift_amount), {x=y}+{x<>y}). destruct x as [x Px]. destruct y as [y Py]. destruct (H x y). @@ -846,7 +847,7 @@ Definition is_shift_amount_aux (n: int) : { Int.ltu n Int.iwordsize = true } + { Int.ltu n Int.iwordsize = false }. Proof. - intro. case (Int.ltu n Int.iwordsize). left; auto. right; auto. + case (Int.ltu n Int.iwordsize). left; auto. right; auto. Defined. Definition is_shift_amount (n: int) : option shift_amount := |