summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Dan Liew <daniel.liew@imperial.ac.uk>2014-05-11 15:45:24 +0100
committerGravatar Dan Liew <daniel.liew@imperial.ac.uk>2014-05-11 15:45:24 +0100
commit7b1dd5bcec1db5360bd690ca7c04811012035e19 (patch)
tree274a0d4e55963a6e8aa6ffee7af9d4db13ffe70d
parent8b21cf03acd6506a4d965607a3782953e9a50189 (diff)
Remove some legacy test infrastructure for OSX/Linux
-rw-r--r--Test/Makefile20
-rw-r--r--Test/filter.pl38
-rwxr-xr-xTest/rtest25
-rwxr-xr-xTest/rtestall32
4 files changed, 0 insertions, 115 deletions
diff --git a/Test/Makefile b/Test/Makefile
deleted file mode 100644
index 29e8c844..00000000
--- a/Test/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-TESTS_FILE = alltests.txt
-LONG = $(shell awk '{ if (tolower($$2) ~ /^long$$/) print $$1 }' $(TESTS_FILE))
-NORMAL = $(shell awk '{ if (tolower($$2) ~ /^use$$/) print $$1 }' $(TESTS_FILE))
-TESTS = $(NORMAL)
-
-all: boogie
-
-boogie: $(addprefix run-, $(TESTS))
-
-show:
- @echo $(TESTS)
-
-long:
- $(MAKE) TESTS="$(NORMAL) $(LONG)" all
-
-run-%:
- @if ls -f $*/*.dfy >/dev/null 2>&1 ; then true ; else cmd /c "runtest.bat $* $(FLAGS)" ; fi || :
-
-rundfy-%:
- @if ls -f $*/*.dfy >/dev/null 2>&1 ; then cmd /c "runtest.bat $* $(FLAGS)" ; fi || :
diff --git a/Test/filter.pl b/Test/filter.pl
deleted file mode 100644
index c95a7e4f..00000000
--- a/Test/filter.pl
+++ /dev/null
@@ -1,38 +0,0 @@
-$numargs = $#ARGV + 1;
-
-($numargs == 2) || die "usage: filter.pl input-log output-log\n";
-
-$input = $ARGV[0];
-$output = $ARGV[1];
-
-open(IN, "<$input") || die "can't open $input";
-open(OUT, ">$output") || die "can't open $output";
-
-my @array = ();
-
-while (<IN>) {
- s/^\s*.:.*\\//;
- s/^Microsoft .*//;
- s/^for Microsoft \(R\) .NET.*//;
- s/^Copyright \(C\).*//;
- if ($_ !~ m/^\s*$/) # don't write out blank lines
- {
- push(@array, ($_));
- }
-}
-
-#
-# if we want to compare only sorted output uncomment this
-#@sorted = sort(@array);
-@sorted = @array;
-
-
-# eliminate duplicates in the output
-$last = "";
-foreach (@sorted)
-{
- if ($_ ne $last) {
- print(OUT $_);
- $last = $_;
- }
-}
diff --git a/Test/rtest b/Test/rtest
deleted file mode 100755
index 83e9195e..00000000
--- a/Test/rtest
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/usr/bin/bash
-
-if [ $# -eq 0 ] ; then
- echo "rtest: Error: Syntax: rtest testDirectory [ additionalTestArguments ... ]"
- exit 1
-elif [ ! -d "$1" ] ; then
- echo rtest: Error: There is no test directory $1
- exit 1
-fi
-
-TESTDIR=$1
-echo ----- Running regression test $TESTDIR
-cd $TESTDIR
-
-shift
-sh runtest.sh /nologo /logPrefix:$TESTDIR "$@" > Output
-# perl ../filter.pl Output Output.filtered
-# perl ../filter.pl Answer Answer.filtered
-# diff -w Answer.filtered Output.filtered > Diffs
-if cmp /W Answer Output > /dev/null ; then
- echo Succeeded
-else
- echo FAILED
-fi
-cd ..
diff --git a/Test/rtestall b/Test/rtestall
deleted file mode 100755
index 64d0aaa5..00000000
--- a/Test/rtestall
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/bash
-
-if [ "$1" == "short" ] ; then
- shift
- ALL_TESTS=`cat alltests.txt | grep -E "^[^[:space:]]+[[:space:]]+Use[[:space:]]" | awk '{print $1}'`
-elif [ "$1" == "long" ] ; then
- shift
- ALL_TESTS=`cat alltests.txt | grep -E "^[^[:space:]]+[[:space:]]+Long[[:space:]]" | awk '{print $1}'`
-else
- ALL_TESTS=`cat alltests.txt | grep -E "^[^[:space:]]+[[:space:]]+(Use|Long)[[:space:]]" | awk '{print $1}'`
-fi
-
-if [ "$1" == "time" ] ; then
- shift
- TIME_CMD="time -p"
-else
- TIME_CMD=""
-fi
-
-if [ "$1" == "reverse" ] || [ "$1" == "rev" ]; then
- shift
- ALL_TESTS=`echo ${ALL_TESTS} | sed -e 's/ /\n/g' | awk '{a[NR] = $0} END { for(i=NR; i; --i) print a[i]}'`
-fi
-
-for t in ${ALL_TESTS} ; do
- # ${TIME_CMD} bash rtest $t "$@"
- if [ "${TIME_CMD}" == "" ] ; then
- sh runtest.sh $t "$@"
- else
- time -p sh runtest.sh $t "$@"
- fi
-done