summaryrefslogtreecommitdiff
path: root/absl/profiling/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/profiling/CMakeLists.txt')
-rw-r--r--absl/profiling/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/absl/profiling/CMakeLists.txt b/absl/profiling/CMakeLists.txt
index 3c37491e..7b6a7780 100644
--- a/absl/profiling/CMakeLists.txt
+++ b/absl/profiling/CMakeLists.txt
@@ -12,3 +12,28 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+absl_cc_library(
+ NAME
+ sample_recorder
+ HDRS
+ "internal/sample_recorder.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ DEPS
+ absl::base
+ absl::synchronization
+)
+
+absl_cc_test(
+ NAME
+ sample_recorder_test
+ SRCS
+ "internal/sample_recorder_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::sample_recorder
+ absl::time
+ GTest::gmock_main
+)
+