summaryrefslogtreecommitdiff
path: root/absl/base
diff options
context:
space:
mode:
Diffstat (limited to 'absl/base')
-rw-r--r--absl/base/BUILD.bazel2
-rw-r--r--absl/base/CMakeLists.txt2
-rw-r--r--absl/base/internal/raw_logging.cc2
-rw-r--r--absl/base/internal/raw_logging.h2
-rw-r--r--absl/base/log_severity.h (renamed from absl/base/internal/log_severity.h)0
5 files changed, 4 insertions, 4 deletions
diff --git a/absl/base/BUILD.bazel b/absl/base/BUILD.bazel
index 609d78ad..1778f4f8 100644
--- a/absl/base/BUILD.bazel
+++ b/absl/base/BUILD.bazel
@@ -151,7 +151,6 @@ cc_library(
"casts.h",
"internal/atomic_hook.h",
"internal/cycleclock.h",
- "internal/log_severity.h",
"internal/low_level_scheduling.h",
"internal/per_thread_tls.h",
"internal/raw_logging.h",
@@ -160,6 +159,7 @@ cc_library(
"internal/thread_identity.h",
"internal/tsan_mutex_interface.h",
"internal/unscaledcycleclock.h",
+ "log_severity.h",
],
copts = ABSL_DEFAULT_COPTS,
deps = [
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index cb0daa69..d3066163 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -20,6 +20,7 @@ list(APPEND BASE_PUBLIC_HEADERS
"casts.h"
"config.h"
"dynamic_annotations.h"
+ "log_severity.h"
"macros.h"
"optimization.h"
"policy_checks.h"
@@ -36,7 +37,6 @@ list(APPEND BASE_INTERNAL_HEADERS
"internal/exception_safety_testing.h"
"internal/identity.h"
"internal/invoke.h"
- "internal/log_severity.h"
"internal/low_level_alloc.h"
"internal/low_level_scheduling.h"
"internal/malloc_extension.h"
diff --git a/absl/base/internal/raw_logging.cc b/absl/base/internal/raw_logging.cc
index 301b108c..86e34d45 100644
--- a/absl/base/internal/raw_logging.cc
+++ b/absl/base/internal/raw_logging.cc
@@ -22,7 +22,7 @@
#include "absl/base/config.h"
#include "absl/base/internal/atomic_hook.h"
-#include "absl/base/internal/log_severity.h"
+#include "absl/base/log_severity.h"
// We know how to perform low-level writes to stderr in POSIX and Windows. For
// these platforms, we define the token ABSL_LOW_LEVEL_WRITE_SUPPORTED.
diff --git a/absl/base/internal/raw_logging.h b/absl/base/internal/raw_logging.h
index 568d2afc..1b2a44b7 100644
--- a/absl/base/internal/raw_logging.h
+++ b/absl/base/internal/raw_logging.h
@@ -20,7 +20,7 @@
#define ABSL_BASE_INTERNAL_RAW_LOGGING_H_
#include "absl/base/attributes.h"
-#include "absl/base/internal/log_severity.h"
+#include "absl/base/log_severity.h"
#include "absl/base/macros.h"
#include "absl/base/port.h"
diff --git a/absl/base/internal/log_severity.h b/absl/base/log_severity.h
index deaf6a57..deaf6a57 100644
--- a/absl/base/internal/log_severity.h
+++ b/absl/base/log_severity.h