summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--absl/container/BUILD.bazel4
-rw-r--r--absl/container/CMakeLists.txt4
-rw-r--r--absl/container/internal/layout_test.cc7
-rw-r--r--absl/container/internal/raw_hash_set_allocator_test.cc10
-rw-r--r--absl/flags/BUILD.bazel2
-rw-r--r--absl/flags/CMakeLists.txt1
-rw-r--r--absl/flags/internal/usage.cc5
-rw-r--r--absl/hash/BUILD.bazel4
-rw-r--r--absl/hash/CMakeLists.txt14
-rw-r--r--absl/hash/hash_benchmark.cc6
-rw-r--r--absl/hash/hash_test.cc24
-rw-r--r--absl/time/duration.cc6
12 files changed, 56 insertions, 31 deletions
diff --git a/absl/container/BUILD.bazel b/absl/container/BUILD.bazel
index f22da59a..a1f6fd4f 100644
--- a/absl/container/BUILD.bazel
+++ b/absl/container/BUILD.bazel
@@ -710,7 +710,7 @@ cc_test(
deps = [
":raw_hash_set",
":tracked",
- "//absl/base:core_headers",
+ "//absl/base:config",
"@com_google_googletest//:gtest_main",
],
)
@@ -741,9 +741,9 @@ cc_test(
deps = [
":layout",
"//absl/base:config",
- "//absl/base:core_headers",
"//absl/log:check",
"//absl/types:span",
+ "//absl/utility",
"@com_google_googletest//:gtest_main",
],
)
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 39d95e02..f3443a66 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -754,9 +754,9 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
+ absl::config
absl::raw_hash_set
absl::tracked
- absl::core_headers
GTest::gmock_main
)
@@ -789,8 +789,8 @@ absl_cc_test(
absl::layout
absl::check
absl::config
- absl::core_headers
absl::span
+ absl::utility
GTest::gmock_main
)
diff --git a/absl/container/internal/layout_test.cc b/absl/container/internal/layout_test.cc
index ce599ce7..ae55cf7e 100644
--- a/absl/container/internal/layout_test.cc
+++ b/absl/container/internal/layout_test.cc
@@ -19,8 +19,12 @@
#include <stddef.h>
#include <cstdint>
+#include <cstring>
+#include <initializer_list>
#include <memory>
-#include <sstream>
+#include <ostream>
+#include <string>
+#include <tuple>
#include <type_traits>
#include "gmock/gmock.h"
@@ -28,6 +32,7 @@
#include "absl/base/config.h"
#include "absl/log/check.h"
#include "absl/types/span.h"
+#include "absl/utility/utility.h"
namespace absl {
ABSL_NAMESPACE_BEGIN
diff --git a/absl/container/internal/raw_hash_set_allocator_test.cc b/absl/container/internal/raw_hash_set_allocator_test.cc
index e73f53fd..53cc5180 100644
--- a/absl/container/internal/raw_hash_set_allocator_test.cc
+++ b/absl/container/internal/raw_hash_set_allocator_test.cc
@@ -12,10 +12,18 @@
// See the License for the specific language governing permissions and
// limitations under the License.
+#include <cstddef>
+#include <cstdint>
+#include <functional>
#include <limits>
-#include <scoped_allocator>
+#include <memory>
+#include <ostream>
+#include <set>
+#include <type_traits>
+#include <utility>
#include "gtest/gtest.h"
+#include "absl/base/config.h"
#include "absl/container/internal/raw_hash_set.h"
#include "absl/container/internal/tracked.h"
diff --git a/absl/flags/BUILD.bazel b/absl/flags/BUILD.bazel
index 50bf387c..65577a9b 100644
--- a/absl/flags/BUILD.bazel
+++ b/absl/flags/BUILD.bazel
@@ -266,8 +266,8 @@ cc_library(
":reflection",
"//absl/base:config",
"//absl/base:core_headers",
- "//absl/container:flat_hash_map",
"//absl/strings",
+ "//absl/synchronization",
],
)
diff --git a/absl/flags/CMakeLists.txt b/absl/flags/CMakeLists.txt
index b20463f5..a535b55e 100644
--- a/absl/flags/CMakeLists.txt
+++ b/absl/flags/CMakeLists.txt
@@ -243,7 +243,6 @@ absl_cc_library(
absl::flags_private_handle_accessor
absl::flags_program_name
absl::flags_reflection
- absl::flat_hash_map
absl::strings
absl::synchronization
)
diff --git a/absl/flags/internal/usage.cc b/absl/flags/internal/usage.cc
index 13852e14..8b169bcd 100644
--- a/absl/flags/internal/usage.cc
+++ b/absl/flags/internal/usage.cc
@@ -27,7 +27,10 @@
#include <utility>
#include <vector>
+#include "absl/base/attributes.h"
#include "absl/base/config.h"
+#include "absl/base/const_init.h"
+#include "absl/base/thread_annotations.h"
#include "absl/flags/commandlineflag.h"
#include "absl/flags/flag.h"
#include "absl/flags/internal/flag.h"
@@ -40,6 +43,8 @@
#include "absl/strings/str_cat.h"
#include "absl/strings/str_split.h"
#include "absl/strings/string_view.h"
+#include "absl/strings/strip.h"
+#include "absl/synchronization/mutex.h"
// Dummy global variables to prevent anyone else defining these.
bool FLAGS_help = false;
diff --git a/absl/hash/BUILD.bazel b/absl/hash/BUILD.bazel
index 4346fc49..a520ae62 100644
--- a/absl/hash/BUILD.bazel
+++ b/absl/hash/BUILD.bazel
@@ -85,9 +85,13 @@ cc_test(
"//absl/container:flat_hash_set",
"//absl/container:node_hash_map",
"//absl/container:node_hash_set",
+ "//absl/memory",
"//absl/meta:type_traits",
"//absl/numeric:int128",
"//absl/strings:cord_test_helpers",
+ "//absl/strings:string_view",
+ "//absl/types:optional",
+ "//absl/types:variant",
"@com_google_googletest//:gtest_main",
],
)
diff --git a/absl/hash/CMakeLists.txt b/absl/hash/CMakeLists.txt
index 65fd2a5f..438c1cda 100644
--- a/absl/hash/CMakeLists.txt
+++ b/absl/hash/CMakeLists.txt
@@ -68,18 +68,22 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
+ absl::btree
absl::cord_test_helpers
- absl::hash
- absl::hash_testing
absl::core_headers
- absl::btree
absl::flat_hash_map
absl::flat_hash_set
+ absl::hash
+ absl::hash_testing
+ absl::int128
+ absl::memory
+ absl::meta
absl::node_hash_map
absl::node_hash_set
+ absl::optional
absl::spy_hash_state
- absl::meta
- absl::int128
+ absl::string_view
+ absl::variant
GTest::gmock_main
)
diff --git a/absl/hash/hash_benchmark.cc b/absl/hash/hash_benchmark.cc
index 8712a01c..916fb620 100644
--- a/absl/hash/hash_benchmark.cc
+++ b/absl/hash/hash_benchmark.cc
@@ -12,7 +12,13 @@
// See the License for the specific language governing permissions and
// limitations under the License.
+#include <algorithm>
+#include <cassert>
+#include <cstddef>
+#include <cstdint>
+#include <cstring>
#include <string>
+#include <tuple>
#include <type_traits>
#include <typeindex>
#include <utility>
diff --git a/absl/hash/hash_test.cc b/absl/hash/hash_test.cc
index a0e2e4a7..111f375b 100644
--- a/absl/hash/hash_test.cc
+++ b/absl/hash/hash_test.cc
@@ -17,42 +17,36 @@
#include <algorithm>
#include <array>
#include <bitset>
+#include <cstddef>
#include <cstdint>
+#include <cstdlib>
#include <cstring>
-#include <deque>
-#include <forward_list>
#include <functional>
#include <initializer_list>
-#include <iterator>
+#include <ios>
#include <limits>
-#include <list>
-#include <map>
#include <memory>
-#include <numeric>
-#include <random>
+#include <ostream>
#include <set>
#include <string>
#include <tuple>
#include <type_traits>
#include <unordered_map>
-#include <unordered_set>
#include <utility>
#include <vector>
-#include "gmock/gmock.h"
#include "gtest/gtest.h"
-#include "absl/container/btree_map.h"
-#include "absl/container/btree_set.h"
-#include "absl/container/flat_hash_map.h"
+#include "absl/base/config.h"
#include "absl/container/flat_hash_set.h"
-#include "absl/container/node_hash_map.h"
-#include "absl/container/node_hash_set.h"
#include "absl/hash/hash_testing.h"
#include "absl/hash/internal/hash_test.h"
#include "absl/hash/internal/spy_hash_state.h"
+#include "absl/memory/memory.h"
#include "absl/meta/type_traits.h"
-#include "absl/numeric/int128.h"
#include "absl/strings/cord_test_helpers.h"
+#include "absl/strings/string_view.h"
+#include "absl/types/optional.h"
+#include "absl/types/variant.h"
#ifdef ABSL_HAVE_STD_STRING_VIEW
#include <string_view>
diff --git a/absl/time/duration.cc b/absl/time/duration.cc
index 634e5d58..bdb16e21 100644
--- a/absl/time/duration.cc
+++ b/absl/time/duration.cc
@@ -55,8 +55,7 @@
#include <algorithm>
#include <cassert>
-#include <cctype>
-#include <cerrno>
+#include <chrono> // NOLINT(build/c++11)
#include <cmath>
#include <cstdint>
#include <cstdlib>
@@ -66,8 +65,9 @@
#include <limits>
#include <string>
+#include "absl/base/attributes.h"
#include "absl/base/casts.h"
-#include "absl/base/macros.h"
+#include "absl/base/config.h"
#include "absl/numeric/int128.h"
#include "absl/strings/string_view.h"
#include "absl/strings/strip.h"