summaryrefslogtreecommitdiff
path: root/debian/tests
diff options
context:
space:
mode:
authorGravatar Pirate Praveen <praveen@debian.org>2023-03-06 20:25:41 +0530
committerGravatar Pirate Praveen <praveen@debian.org>2023-03-06 20:25:41 +0530
commit079dd8737bbaaaeeca3a95c2b858a62d8a620d5a (patch)
tree6af54966e17bcfe48ecdb0b5cdf43cc953d5358c /debian/tests
parent2bbc47f307f1e24f3f44a108d571bffa5a3faa63 (diff)
parentf5afcb784c9b1c501c1144b7aab84555881ca871 (diff)
Merge tag '20220623.1-1' into bullseye-backports-staging
Diffstat (limited to 'debian/tests')
-rwxr-xr-xdebian/tests/bug101129424
-rwxr-xr-xdebian/tests/cmake2
-rw-r--r--debian/tests/control3
3 files changed, 28 insertions, 1 deletions
diff --git a/debian/tests/bug1011294 b/debian/tests/bug1011294
new file mode 100755
index 00000000..302bcf73
--- /dev/null
+++ b/debian/tests/bug1011294
@@ -0,0 +1,24 @@
+#!/bin/sh
+# Copyright 2022 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+set -eu
+
+readonly TMP="$(mktemp -d)"
+trap "rm -rf \"$TMP\"" EXIT
+cd "$TMP"
+
+echo 'int main() {}' >noop.cc
+
+g++ -o noop noop.cc $(pkg-config --cflags absl_base) $(pkg-config --libs absl_base)
diff --git a/debian/tests/cmake b/debian/tests/cmake
index 1eb04de9..43eb3408 100755
--- a/debian/tests/cmake
+++ b/debian/tests/cmake
@@ -32,7 +32,7 @@ EOF
cat >CMakeLists.txt <<EOF
cmake_minimum_required(VERSION 3.5)
project(test CXX)
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
add_executable(test test.cc)
find_package(absl REQUIRED)
target_link_libraries(test absl::strings)
diff --git a/debian/tests/control b/debian/tests/control
index 43dc87cb..161ef695 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -17,3 +17,6 @@ Depends: @, g++, libgtest-dev
Tests: cmake
Depends: @, cmake (>= 3.5), g++, make
+
+Tests: bug1011294
+Depends: @, g++, pkg-config