summaryrefslogtreecommitdiff
path: root/absl/types
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2018-01-30 13:05:25 -0800
committerGravatar Jon Cohen <cohenjon@google.com>2018-01-30 16:52:52 -0500
commitf4f238b09bc365e355ce404d02c7d7fd02662597 (patch)
tree53e7070c9075cd9ccbdc1c03dd120c8f04348325 /absl/types
parente5c6ee2d0032d08f4d7a4680c13b9e2e5787ac26 (diff)
Changes imported from Abseil "staging" branch:
- c77facb7ba7c12d656e213e5d63d7dcd9d1f56ba Present the Writer* methods as an option, rather than an ... by Abseil Team <absl-team@google.com> - c6004d718f185868dee2ec48b4de6425399b062d Split exception_safety_testing out into its own cmake rul... by Jon Cohen <cohenjon@google.com> - 9aa6fc7b34674472d808ed8021f3b20faea82f78 Downstream https://github.com/abseil/abseil-cpp/pull/69 by Jon Cohen <cohenjon@google.com> - 13d340269f284b815cc409d2271099e535f4cba4 Internal change by Jon Cohen <cohenjon@google.com> - 51840a9243ac9d47eb3c177398d10bb3341f3230 Fix assertion in conversion from floating point types to ... by Alex Strelnikov <strel@google.com> GitOrigin-RevId: c77facb7ba7c12d656e213e5d63d7dcd9d1f56ba Change-Id: I7590561b04a986ffbec7139bb9c3aea319a3b975
Diffstat (limited to 'absl/types')
-rw-r--r--absl/types/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/absl/types/CMakeLists.txt b/absl/types/CMakeLists.txt
index b2d95b48..fd71f38b 100644
--- a/absl/types/CMakeLists.txt
+++ b/absl/types/CMakeLists.txt
@@ -130,7 +130,7 @@ absl_test(
# test any_exception_safety_test
set(ANY_EXCEPTION_SAFETY_TEST_SRC "any_exception_safety_test.cc")
-set(ANY_EXCEPTION_SAFETY_TEST_PUBLIC_LIBRARIES absl::any absl::base)
+set(ANY_EXCEPTION_SAFETY_TEST_PUBLIC_LIBRARIES absl::any absl::base absl::base_internal_exception_safety_testing)
absl_test(
TARGET