summaryrefslogtreecommitdiff
path: root/absl/types
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2021-04-14 11:19:20 -0700
committerGravatar Dino Radaković <dinor@google.com>2021-04-14 16:12:56 -0700
commit46dfbfe31ca1dd414e4c33cbcbcd7199bb4efde3 (patch)
tree085be065bb9348c8d569e2ede8a9fa8b54f085bc /absl/types
parentdb1b7310d7021700b5a7bcea1989b2a625529f40 (diff)
Export of internal Abseil changes
-- 5ff0c4b38386ae80b25e9f8d0e1bac07fd7ce92c by Martijn Vels <mvels@google.com>: Add CordzUpdateTracker class PiperOrigin-RevId: 368469046 -- 4de916b1ba4b5480b4dbe93d28c5eaa110449c66 by Derek Mauro <dmauro@google.com>: Adds `ABSL_ATTRIBUTE_LIFETIME_BOUND` to `absl::Span`s initializer_list constructor. Compilers that support this attribute will emit a warning if the parameter does not have sufficient lifetime. For more information, see https://github.com/abseil/abseil-cpp/blob/b97a1ecda869ca8754d467a56c50275cebfeb328/absl/types/span.h#L209-L248 PiperOrigin-RevId: 368429085 -- bb6669016412bf5afffc02d0818a66dfe1c524cf by Martijn Vels <mvels@google.com>: Reorganize internal cord code in CMakeLists.txt into cord_internal library PiperOrigin-RevId: 368423765 -- d1d7fce066172d5fcfa0310c4e27631d895d7e50 by Derek Mauro <dmauro@google.com>: Internal change PiperOrigin-RevId: 368346725 GitOrigin-RevId: 5ff0c4b38386ae80b25e9f8d0e1bac07fd7ce92c Change-Id: Ic4627eab4f0274e400a6d12cde3341fb538de075
Diffstat (limited to 'absl/types')
-rw-r--r--absl/types/span.h4
1 files changed, 2 insertions, 2 deletions
diff --git a/absl/types/span.h b/absl/types/span.h
index 95fe7926..41db3420 100644
--- a/absl/types/span.h
+++ b/absl/types/span.h
@@ -243,8 +243,8 @@ class Span {
//
template <typename LazyT = T,
typename = EnableIfConstView<LazyT>>
- Span(
- std::initializer_list<value_type> v) noexcept // NOLINT(runtime/explicit)
+ Span(std::initializer_list<value_type> v
+ ABSL_ATTRIBUTE_LIFETIME_BOUND) noexcept // NOLINT(runtime/explicit)
: Span(v.begin(), v.size()) {}
// Accessors