summaryrefslogtreecommitdiff
path: root/absl/strings
diff options
context:
space:
mode:
authorGravatar Derek Mauro <dmauro@google.com>2024-07-18 07:03:57 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2024-07-18 07:04:49 -0700
commit0598e582f659594aa3592c70ba7dcb251649d264 (patch)
tree338f11f65fa676f230cbb39ad4d9b00ba9969e2c /absl/strings
parent7795d0843a72b6c2994941763aee14519bbcfccd (diff)
Delete absl/strings/internal/has_absl_stringify.h now that the
GoogleTest version we depend on uses the public file PiperOrigin-RevId: 653606441 Change-Id: Id49b18835443162ddf9747cc31619f3acf01f4ef
Diffstat (limited to 'absl/strings')
-rw-r--r--absl/strings/BUILD.bazel1
-rw-r--r--absl/strings/CMakeLists.txt1
-rw-r--r--absl/strings/internal/has_absl_stringify.h54
3 files changed, 0 insertions, 56 deletions
diff --git a/absl/strings/BUILD.bazel b/absl/strings/BUILD.bazel
index 9bffae61..2cc014ed 100644
--- a/absl/strings/BUILD.bazel
+++ b/absl/strings/BUILD.bazel
@@ -77,7 +77,6 @@ cc_library(
"escaping.h",
"has_absl_stringify.h",
"internal/damerau_levenshtein_distance.h",
- "internal/has_absl_stringify.h",
"internal/string_constant.h",
"match.h",
"numbers.h",
diff --git a/absl/strings/CMakeLists.txt b/absl/strings/CMakeLists.txt
index 4a84dbbd..3a1619e8 100644
--- a/absl/strings/CMakeLists.txt
+++ b/absl/strings/CMakeLists.txt
@@ -42,7 +42,6 @@ absl_cc_library(
"has_absl_stringify.h"
"internal/damerau_levenshtein_distance.h"
"internal/string_constant.h"
- "internal/has_absl_stringify.h"
"match.h"
"numbers.h"
"str_cat.h"
diff --git a/absl/strings/internal/has_absl_stringify.h b/absl/strings/internal/has_absl_stringify.h
deleted file mode 100644
index 98f27dff..00000000
--- a/absl/strings/internal/has_absl_stringify.h
+++ /dev/null
@@ -1,54 +0,0 @@
-// Copyright 2024 The Abseil Authors
-//
-// Licensed under the Apache License, Version 2.0 (the "License");
-// you may not use this file except in compliance with the License.
-// You may obtain a copy of the License at
-//
-// https://www.apache.org/licenses/LICENSE-2.0
-//
-// Unless required by applicable law or agreed to in writing, software
-// distributed under the License is distributed on an "AS IS" BASIS,
-// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-// See the License for the specific language governing permissions and
-// limitations under the License.
-
-#ifndef ABSL_STRINGS_INTERNAL_HAS_ABSL_STRINGIFY_H_
-#define ABSL_STRINGS_INTERNAL_HAS_ABSL_STRINGIFY_H_
-
-#include "absl/strings/has_absl_stringify.h"
-
-#include <type_traits>
-#include <utility>
-
-#include "absl/base/config.h"
-
-namespace absl {
-ABSL_NAMESPACE_BEGIN
-
-namespace strings_internal {
-
-// This exists to fix a circular dependency problem with the GoogleTest release.
-// GoogleTest referenced this internal file and this internal trait. Since
-// simultaneous releases are not possible since once release must reference
-// another, we will temporarily add this back.
-// https://github.com/google/googletest/blob/v1.14.x/googletest/include/gtest/gtest-printers.h#L119
-//
-// This file can be deleted after the next Abseil and GoogleTest release.
-//
-// https://github.com/google/googletest/pull/4368#issuecomment-1717699895
-// https://github.com/google/googletest/pull/4368#issuecomment-1717699895
-template <typename T, typename = void>
-struct HasAbslStringify : std::false_type {};
-
-template <typename T>
-struct HasAbslStringify<
- T, std::enable_if_t<std::is_void<decltype(AbslStringify(
- std::declval<strings_internal::UnimplementedSink&>(),
- std::declval<const T&>()))>::value>> : std::true_type {};
-
-} // namespace strings_internal
-
-ABSL_NAMESPACE_END
-} // namespace absl
-
-#endif // ABSL_STRINGS_INTERNAL_HAS_ABSL_STRINGIFY_H_