summaryrefslogtreecommitdiff
path: root/absl/random/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Justin Bassett <jbassett@google.com>2024-05-21 16:56:45 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2024-05-21 16:57:23 -0700
commite7f1a950e97b805d634909124fa4c75b690d0475 (patch)
tree8d0c6417c27f468083cc36126da4282678607eaf /absl/random/CMakeLists.txt
parenta2625a648dc69c5b3d0330f25004454716cacfc8 (diff)
Support int128/uint128 in validated MockingBitGen
`absl::int128` and `absl::uint128` are not `std::is_integral`. There is an internal `IsIntegral` type trait we could use, but it actually makes more sense to remove the `static_assert` altogether. Any compile-time validation should be done in `absl::Uniform` itself, and duplicating that logic here just increases the chance of divergence. PiperOrigin-RevId: 635971431 Change-Id: I9177ae64c86ee1abe6571e0b29aba1844553c972
Diffstat (limited to 'absl/random/CMakeLists.txt')
-rw-r--r--absl/random/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/random/CMakeLists.txt b/absl/random/CMakeLists.txt
index 3cf65b69..56bbfd81 100644
--- a/absl/random/CMakeLists.txt
+++ b/absl/random/CMakeLists.txt
@@ -1206,6 +1206,7 @@ absl_cc_test(
DEPS
absl::random_internal_uniform_helper
GTest::gtest_main
+ absl::int128
)
# Internal-only target, do not depend on directly.